wxRichToolTip Message font

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
sivaranjani
Earned a small fee
Earned a small fee
Posts: 18
Joined: Wed Mar 14, 2018 10:43 am

wxRichToolTip Message font

Post by sivaranjani » Thu Oct 15, 2020 5:33 am

Hi,

Is it possible to set style and font of message in wxRichToolTip?
SetFontTitle() function setfont only to title.


Thanks,
ranjani.

User avatar
doublemax
Moderator
Moderator
Posts: 15154
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxRichToolTip Message font

Post by doublemax » Thu Oct 15, 2020 9:23 am

I don't see any way to do that.
Use the source, Luke!

sivaranjani
Earned a small fee
Earned a small fee
Posts: 18
Joined: Wed Mar 14, 2018 10:43 am

Re: wxRichToolTip Message font

Post by sivaranjani » Sat Oct 17, 2020 4:03 pm

how can i close wxrichtooltip ?
On mouse click its not closed inconsistently.After this,if clicked anywhere its crashing.

Code: Select all

wxRichToolTip tip("ToolTip ","Test");
tip.SetBackgroundColour(wxColour(*wxLIGHT_GREY));
tip.SetTimeout(0, 0);
tip.ShowFor(pWindow);
Thanks,
ranjani

User avatar
doublemax
Moderator
Moderator
Posts: 15154
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxRichToolTip Message font

Post by doublemax » Sat Oct 17, 2020 10:29 pm

Which wxWidgets version are you using? There is an older ticket about an wxRichtoolTip related crash:
http://trac.wxwidgets.org/ticket/17871
Use the source, Luke!

sivaranjani
Earned a small fee
Earned a small fee
Posts: 18
Joined: Wed Mar 14, 2018 10:43 am

Re: wxRichToolTip Message font

Post by sivaranjani » Sun Oct 18, 2020 4:15 am

It's wxwidgets 3.0 version.

Thanks,
Ranjani

User avatar
doublemax
Moderator
Moderator
Posts: 15154
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxRichToolTip Message font

Post by doublemax » Sun Oct 18, 2020 7:20 am

sivaranjani wrote:
Sun Oct 18, 2020 4:15 am
It's wxwidgets 3.0 version.
That's pretty old. Please try again with a recent wxWidgets version (3.1.4).
Use the source, Luke!

Post Reply