error compiling wxwidgets 3.1.3 with mingw and msys

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Sat Nov 02, 2019 6:14 pm

Hello to all

I use msys because I can compile in the same way on windows and on ubuntu both system without problems,
it would take a list of the compilers that are supported by wxwidgets to create accessibility so it's easy to understand the compatible compiler to use accessibility on wxwidgets

I following post an old discussion from 2005 where the compilers that were compatible in 2005 are recommended the wxwidgets version 3.0.4 still supported these compilers
Post by leio » Wed Sep 28, 2005 11:47 am
You need to (re)compile wxMSW with accessibility support, by editing the setup.h and making wxUSE_ACCESSIBILITY 1 there, instead of 0. If you are using ./configure, then there is an argument that you can pass for that.
i said wxMSW, because this works only in wxMSW. Enabling wxUSE_ACCESSIBILITY will only give build errors on other ports, as it is not implemented, nor stubbed. Further, the API is so win32 centric, that I don't really see it possible to implement it on other ports in any sane way with the given API of current wxAccessible.

Compilers: gcc-3.3.6, gcc-3.4.5, gcc-4.0.2, gcc-4.1.0 and MSVC6
OS's: Gentoo Linux, WinXP; WX: CVS HEAD
here is the link to the full discussion which I based for accessibility:

Building Error (wxUSE_ACCESSIBILITY)


I don't think that anything else has been done for accessibility in these 14 years

if anyone has news, don't hesitate to post

thanks

Marco_84

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 283
Joined: Fri Nov 03, 2006 2:00 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by stahta01 » Sun Nov 03, 2019 11:31 pm

I have no reason to believe that newer mingw GCC compilers do not support accessibility.
Do you have reason to believe they do not?

Tim S.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Mon Nov 04, 2019 5:38 pm

Hello at all forum I inform you that I succeeded !!!

Is true stahta01 is exactly you wrote, I tried to install wxwidgets on another version of mingw with gcc 6.3.0 and it was installed without errors, I tried to compile a project that contains the treelist, when I launched the project, the screen reader has begun to read inside the treelist with the changes made for accessibility without passing specific parameters during the installation of the wxwidgets and during the compilation of the project, I was surprised I did not expect it ... wow


now I need a command and I'm done:
I downloaded the version of mingw64 and msys2, I wanted to know which is the correct string of the ./configure command to type in the prompt on the msys2 by compiling the monolithic and static library which return less dll possible (because I hate them)

thanks for your help and for your time lost for me


Marco_84

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3508
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by ONEEYEMAN » Mon Nov 04, 2019 5:52 pm

Hi,
If you will do "static" build of the library - there will be no dll produced. Everythiong will be compiled in.
So you can successfully remove the "monolithic" from the compilation.

In fact - do not do monolithic build at all. It will give you more headache in the future.

Thank you.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Mon Nov 04, 2019 6:25 pm

Hello ONEEYEMAN how should I change this command string to have the compilation without dll?

Code: Select all

./configure --prefix=/usr/local/wx-widget-win32/ --host=i586-mingw32msvc --build=i686-linux --enable-monolithic --disable-shared
make
make install 
thanks
Marco_84

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3508
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by ONEEYEMAN » Mon Nov 04, 2019 7:09 pm

Hi,
No change is required - it will not be compiled as dll.
But you should also get rid of "--enable-monolithic". It will not give you any gain.

Thank you.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Mon Nov 04, 2019 7:20 pm

Well
I type this:

Code: Select all

./configure --prefix=/usr/local/wx-widget-win32/ --host=i586-mingw32msvc --build=i686-linux --disable-shared
make
make install

thanks
Marco_84

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 283
Joined: Fri Nov 03, 2006 2:00 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by stahta01 » Mon Nov 04, 2019 9:46 pm

Code: Select all

--host=i586-mingw32msvc --build=i686-linux
Why are you using the above option? Why do you lie to the configure command?

Are you now using msys2 instead of msys from mingw.org?

If yes, then you need to decide if you are doing an 32 bit or 64 bit build of wxWidgets.

Tim S.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Mon Nov 04, 2019 11:01 pm

hello stahta01

no I'm returned at msys 1.0 with gcc v. 9.1.0


so what command should I give to ./configure?

thanks

Marco_84

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 283
Joined: Fri Nov 03, 2006 2:00 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by stahta01 » Mon Nov 04, 2019 11:09 pm

stahta01 wrote:
Fri Nov 01, 2019 6:39 am
No problem when using wxWidgets-3.1.3

Code: Select all

cd C:/wxWidgets-3.1.3

mkdir -p /mingw/local
./configure --prefix=/mingw/local/wx-widget-win32/ \
    --enable-monolithic --disable-shared --enable-accessibility

make && make install

export PATH=/mingw/local/wx-widget-win32/bin:$PATH

cd samples/access && rm -f accesstext.exe && \
g++ accesstest.cpp -o accesstext.exe $(wx-config --cxxflags --libs) && \
accesstext.exe
I would use the above without the "--enable-monolithic".

Tim S.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Mon Nov 04, 2019 11:28 pm

hello stahta01

what?
this isn't possible?

Marco_84

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 283
Joined: Fri Nov 03, 2006 2:00 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by stahta01 » Tue Nov 05, 2019 1:03 am

marco_84 wrote:
Mon Nov 04, 2019 11:28 pm
hello stahta01

what?
this isn't possible?

Marco_84
I have no idea what you are trying to say!

I posted once more the commands I used a day or so ago to do correctly what you was trying to do.

I post it for the third time without code tags in case that is messing up your reading software!

cd C:/wxWidgets-3.1.3

mkdir -p /mingw/local
./configure --prefix=/mingw/local/wx-widget-win32/ \
--disable-shared --enable-accessibility

make && make install

export PATH=/mingw/local/wx-widget-win32/bin:$PATH

cd samples/access && rm -f accesstext.exe && \
g++ accesstest.cpp -o accesstext.exe $(wx-config --cxxflags --libs) && \
accesstext.exe

Tim S.

User avatar
marco_84
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Jul 08, 2019 7:30 pm

Re: error compiling wxwidgets 3.1.3 with mingw and msys

Post by marco_84 » Tue Nov 05, 2019 10:37 am

hello stahta01

I didn't realize that it was enough to copy the command to the msys terminal

thanks

Marco_84

Post Reply