wxLed code pieces missing, usage

Talk here about issues with one of the components hosted at wxCode, or suggest features for it.
p_lu
In need of some credit
In need of some credit
Posts: 9
Joined: Thu Oct 25, 2018 2:04 pm

wxLed code pieces missing, usage

Postby p_lu » Fri Oct 26, 2018 9:25 am

I'm trying to use a simple "indicator" widget that shows on/off/inactive, and the wxLed or wxStateLed
in the "Led" tab of wxSmith seems like the right thing. However, some code pieces, such as led.h
seems missing, as indicated here...

https://stackoverflow.com/questions/423 ... -component

So, I google this and find the following at wxCode, which doesn't have the wxLed thing. The download
is some binary .exe, which is not what I believe I want.

https://sourceforge.net/projects/wxcode ... omponents/

Can anyone help me find the missing led.h (and related stuff, maybe led.cpp), or suggest some
alternative widget(s)? Was wxLed deprecated?

Also, when I instantiate the wxLed, it seems to place at the upper left of the panel (rather
than where I put the mouse), and there doesn't seem to be any positional attributes. Do I
need to put down another widget in the panel first and then put the wxLed inside that widget?
If so, what should that "positioning" widget be?

Thanks in advance.

User avatar
doublemax
Moderator
Moderator
Posts: 12755
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxLed code pieces missing, usage

Postby doublemax » Fri Oct 26, 2018 10:36 am

wxLed is pretty old (2005). Here's an updated version from 2007 :)
viewtopic.php?t=15679

Also check out:
ftp://ftp.koansoftware.com/public/wx/kwxIndCtrl/
Use the source, Luke!


Return to “wxCode”

Who is online

Users browsing this forum: No registered users and 6 guests