System Error Visual Studio 2017

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
amduke65
In need of some credit
In need of some credit
Posts: 8
Joined: Wed Sep 12, 2018 6:08 am

System Error Visual Studio 2017

Postby amduke65 » Wed Sep 12, 2018 6:35 am

Hello,
I am very new to C++ and this toolkit. I am trying to write my first application.

After a couple attempts at building version 3.0.4 with Visual Studio 2017, I have successfully built the toolkit. I have used the Windows Desktop Application as a starting point. I followed the instructions in the installer instructions to get to this point. I am almost there.

I have a simple program that basically just displays a wxFrame and that's it. It compiles fine, no errors are reported and all seems good. However, when I attempt to run the app I get a System Error dialog that pops up stating that the execution cannot proceed because wxbase30ud_vc_x64_custom.dll was not found. Reinstalling the program may fix the problem. I get the same dialog for wxmsw30_ud_core_vc_x64_custom.dll.

I am not sure how to resolve this issue. I suspect it may have something to do with the Linker settings in the project? Can someone please give me some guidance on resolving this issue?

Thank you,

PB
Part Of The Furniture
Part Of The Furniture
Posts: 1734
Joined: Sun Jan 03, 2010 5:45 pm

Re: System Error Visual Studio 2017

Postby PB » Wed Sep 12, 2018 7:21 am

That is because you compiled wxWidgets as DLL but your application cannot find them, as they are probably (assuming your built them successfully) only in your <WXWIN>/lib/vc_x64_dll (or something like that) folder.

You need to either:
* copy the required DLLs to the folder where the executable is.
* make them available by adding the folder with DLLs to the PATH environment variable (preferably by modifying it for your MSVC project instead of adding it for the user).

amduke65
In need of some credit
In need of some credit
Posts: 8
Joined: Wed Sep 12, 2018 6:08 am

Re: System Error Visual Studio 2017

Postby amduke65 » Wed Sep 12, 2018 1:38 pm

Thank you so much. That resolved the issue. I appreciate your help.

User avatar
doublemax
Moderator
Moderator
Posts: 12751
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: System Error Visual Studio 2017

Postby doublemax » Wed Sep 12, 2018 4:23 pm

amduke65 wrote:Thank you so much. That resolved the issue. I appreciate your help.
Another option would have been to use static linking which prevents this kind of problem in the future.
Use the source, Luke!

amduke65
In need of some credit
In need of some credit
Posts: 8
Joined: Wed Sep 12, 2018 6:08 am

Re: System Error Visual Studio 2017

Postby amduke65 » Mon Sep 17, 2018 9:02 am

Thank you, I will keep that in mind. So much to learn. I am grateful for the help.


Return to “Compiler / Linking / IDE Related”

Who is online

Users browsing this forum: No registered users and 8 guests