Using wxDb under wx2.9.x

If you are using the main C++ distribution of wxWidgets, Feel free to ask any question related to wxWidgets development here. This means questions regarding to C++ and wxWidgets, not compile problems.
Post Reply
samsam598
Super wx Problem Solver
Super wx Problem Solver
Posts: 324
Joined: Mon Oct 06, 2008 12:55 pm

Using wxDb under wx2.9.x

Post by samsam598 » Tue Jul 27, 2010 9:02 am

Can I include all wxDB head and src files which provided in wx2.8.x into my project under wx2.9.x and make it work?Or is there anything should I modify in the wxDB files?

Thanks for the help in advance.

Regards,
Sam
Regards,
Sam
-------------------------------------------------------------------
Windows xp
VS.Net 2003/MinGW 3.4.5 C::B character set: UTF-8
wxWidgets github 3.0 RC1 Unicode Static build,Unicode Shared build.

tan
Moderator
Moderator
Posts: 1471
Joined: Tue Nov 14, 2006 7:58 am
Location: Saint-Petersburg, Russia

Re: Using wxDb under wx2.9.x

Post by tan » Tue Jul 27, 2010 11:17 am

Hi
samsam598 wrote:Can I include all wxDB head and src files which provided in wx2.8.x into my project under wx2.9.x and make it work?Or is there anything should I modify in the wxDB files?
You could try it :)
Actually, i had to modify them. I can share my results. It works with trunk 2.9 (didn't try with 2.9.1 official release).
Attachments
db.zip
(60.83 KiB) Downloaded 101 times
OS: Windows XP Pro
Compiler: MSVC++ 7.1
wxWidgets: 2.8.10

samsam598
Super wx Problem Solver
Super wx Problem Solver
Posts: 324
Joined: Mon Oct 06, 2008 12:55 pm

Re: Using wxDb under wx2.9.x

Post by samsam598 » Tue Jul 27, 2010 12:31 pm

tan wrote:Hi
samsam598 wrote:Can I include all wxDB head and src files which provided in wx2.8.x into my project under wx2.9.x and make it work?Or is there anything should I modify in the wxDB files?
You could try it :)
Actually, i had to modify them. I can share my results. It works with trunk 2.9 (didn't try with 2.9.1 official release).
Thank you so much for the sharing.Really appreciated!

Which version of wx2.9 do you mean exactly,could you clarify?I am using wx2.9.0 offical release,does it support?Also do you port wx/dbgrid.h to work under wx2.9.x?It would be grateful if you have a test example.I tested the db example provide by wxDemo-Win but it uses dbgrid...


Thank you again.
Regards,
Sam
-------------------------------------------------------------------
Windows xp
VS.Net 2003/MinGW 3.4.5 C::B character set: UTF-8
wxWidgets github 3.0 RC1 Unicode Static build,Unicode Shared build.

tan
Moderator
Moderator
Posts: 1471
Joined: Tue Nov 14, 2006 7:58 am
Location: Saint-Petersburg, Russia

Re: Using wxDb under wx2.9.x

Post by tan » Wed Jul 28, 2010 5:17 am

samsam598 wrote: Which version of wx2.9 do you mean exactly,could you clarify?
It was 2.9.1 before official release
samsam598 wrote: I am using wx2.9.0 offical release,does it support?
I believe so.
samsam598 wrote: Also do you port wx/dbgrid.h to work under wx2.9.x?
No, i didn't need it :) May be later...
samsam598 wrote: It would be grateful if you have a test example.I tested the db example provide by wxDemo-Win but it uses dbgrid...
Sorry, i don't have time right now :(
OS: Windows XP Pro
Compiler: MSVC++ 7.1
wxWidgets: 2.8.10

Post Reply