Process flow components lib

This forum can be used to talk about general design strategies, new ideas and questions in general related to wxWidgets. If you feel your questions doesn't fit anywhere, put it here.
Post Reply
User avatar
vouk
Earned a small fee
Earned a small fee
Posts: 23
Joined: Fri Feb 15, 2019 7:34 am
Location: Germany
Contact:

Process flow components lib

Post by vouk » Mon May 25, 2020 4:20 pm

Does anybody know if there is a process flow lib for wxWidgets / c++?

I'd like to configure and visualize the processing of data.
Here is a scribble of what I think of:
processflow.png
processflow.png (14.25 KiB) Viewed 344 times
An animated view would be fantastic.

User avatar
doublemax
Moderator
Moderator
Posts: 15064
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Process flow components lib

Post by doublemax » Mon May 25, 2020 4:35 pm

https://wiki.wxwidgets.org/WxFAQ#How_ca ... d_nodes.3F

Unfortunately they all haven't seen updates for years, so getting them to work with the latest wxWidgets version will probably require some work.
Use the source, Luke!

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4356
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: Process flow components lib

Post by ONEEYEMAN » Mon May 25, 2020 10:35 pm

Hi,
I have a wxShapedFramework working with the 3.1.3 on all major platforms.
AFAIR, I didn't need to modify any sources - everything was compiled out of the box.

I didn't try anything else though...

Thank you.

User avatar
vouk
Earned a small fee
Earned a small fee
Posts: 23
Joined: Fri Feb 15, 2019 7:34 am
Location: Germany
Contact:

Re: Process flow components lib

Post by vouk » Thu Sep 17, 2020 11:53 am

I got wxShapeFramework itself with some little changes compiled, yes (Using 3.1.4 now). Still I'm having issues with it and can't get it working.

The linker complains about:

Code: Select all

1>wxmsw28ud_wxsf.lib(CanvasState.obj) : error LNK2001: Nicht aufgelöstes externes Symbol ""void __cdecl wxOnAssert(char const *,int,char const *,char const *,unsigned short const *)" ([email protected]@[email protected])".
I am linking against debug libs, and I do have __WXDEBUG__ and _DEBUG set, but it seems there is no signature ending with unsigned short const *:
wxOnAssert.png
wxOnAssert.png (30.54 KiB) Viewed 60 times

User avatar
doublemax
Moderator
Moderator
Posts: 15064
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: Process flow components lib

Post by doublemax » Thu Sep 17, 2020 12:35 pm

"wxChar" should expand to "unsigned short" in Unicode under Windows. This looks like an ANSI / Unicode mismatch.
Use the source, Luke!

Post Reply