wxWidgets v3.1.2 release is out ;)

Do you like to promote your wxWidgets based application or component!? Post it here and let's see what the critics have to say. Also, if you found that ONE wx component the world needs to know about, put it here for future reference.
Post Reply
tomay3000
Earned some good credits
Earned some good credits
Posts: 140
Joined: Mon Apr 24, 2017 4:23 am

wxWidgets v3.1.2 release is out ;)

Post by tomay3000 » Mon Dec 10, 2018 2:56 pm

Hello,
I just want to announce that wxWidgets v3.1.2 release is out today.
https://github.com/wxWidgets/wxWidgets/releases

Thank you.

gtafan
Earned some good credits
Earned some good credits
Posts: 143
Joined: Wed Mar 29, 2017 9:52 am

Re: wxWidgets v3.1.2 release is out ;)

Post by gtafan » Tue Dec 11, 2018 1:59 pm

But is it a stable version?

User avatar
doublemax
Moderator
Moderator
Posts: 13874
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxWidgets v3.1.2 release is out ;)

Post by doublemax » Tue Dec 11, 2018 2:35 pm

Technically only even minor version numbers indicate a "stable" version (2.6.x, 2.8.x, 3.0.x, 3.2.x etc)
Therefore 3.1.2 is a "development" version.

But "stable" only means that the API is stable, it doesn't mean that it crashes less.

IMHO 3.1.2 is safe to use, even for production.
Use the source, Luke!

gtafan
Earned some good credits
Earned some good credits
Posts: 143
Joined: Wed Mar 29, 2017 9:52 am

Re: wxWidgets v3.1.2 release is out ;)

Post by gtafan » Tue Dec 11, 2018 4:09 pm

doublemax wrote:Technically only even minor version numbers indicate a "stable" version (2.6.x, 2.8.x, 3.0.x, 3.2.x etc)
Therefore 3.1.2 is a "development" version.

But "stable" only means that the API is stable, it doesn't mean that it crashes less.

IMHO 3.1.2 is safe to use, even for production.
OK, so stay with 3.0.x then.

User avatar
cutecode
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 227
Joined: Fri Dec 09, 2016 7:28 am
Contact:

Re: wxWidgets v3.1.2 release is out ;)

Post by cutecode » Fri Dec 14, 2018 9:58 am

gtafan wrote:OK, so stay with 3.0.x then.
I'm using 3.1.1 now and qite happy with this version.
If I find time I'll try to recompile to newer version

THANK YOU
regards,
Alexander Saprykin
www.wxwidgets.ru

Post Reply