prevent overlapping of columns of a grid in wxPython Topic is solved

This forum can be used to talk about general design strategies, new ideas and questions in general related to wxWidgets. If you feel your questions doesn't fit anywhere, put it here.
Post Reply
User avatar
pikkip
Knows some wx things
Knows some wx things
Posts: 37
Joined: Mon Sep 26, 2016 6:08 am

prevent overlapping of columns of a grid in wxPython

Post by pikkip » Tue Sep 27, 2016 5:41 am

I am using a grid with two columns in wxPython. The first column contains very long strings. The problem here is that these strings overlap on to the second column which are empty in the same row. I tried setting FirstGrid.SetDefaultCellOverflow( False) but it did not help. Can anyone help me out in solving this issue??? :(

User avatar
doublemax
Moderator
Moderator
Posts: 14320
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: prevent overlapping of columns of a grid in wxPython

Post by doublemax » Tue Sep 27, 2016 6:48 am

SetDefaultCellOverflow(false) should work. Did you try calling Refresh() afterwards?

If wxPython has a grid demo, check its source. In the C++ sample SetDefaultCellOverflow(false) does work.
Use the source, Luke!

User avatar
pikkip
Knows some wx things
Knows some wx things
Posts: 37
Joined: Mon Sep 26, 2016 6:08 am

Re: prevent overlapping of columns of a grid in wxPython

Post by pikkip » Fri Oct 21, 2016 5:06 am

Thank you for the suggestion

Post Reply