recommendation for Firebird 3

In this forum you can discuss database related issues which can be wxWidgets related, but also generic in nature.
Post Reply
kagi3624
Earned a small fee
Earned a small fee
Posts: 19
Joined: Wed Feb 26, 2020 8:13 am

recommendation for Firebird 3

Post by kagi3624 » Mon Aug 23, 2021 6:31 pm

Hello,

I have a firebird 3 database. What library should I use for mu project with wxWidgets? I have read about the database layer, but the posts were from over 10 years ago and I couldn't find a tutorial for it.

User avatar
doublemax
Moderator
Moderator
Posts: 16383
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: recommendation for Firebird 3

Post by doublemax » Mon Aug 23, 2021 8:29 pm

wxDatabase is the successor to wxDatabaseLayer, but it doesn't support Firebird:
https://github.com/mtangoo/wxDatabase

However, any C++ wrapper/library for Firebird should do, you don't really need anything wxWidgets specific.
Use the source, Luke!

iwbnwif
Super wx Problem Solver
Super wx Problem Solver
Posts: 276
Joined: Tue Mar 19, 2013 8:52 pm

Re: recommendation for Firebird 3

Post by iwbnwif » Tue Aug 24, 2021 10:04 pm

Firebird now has its own C++ API which is quite straightforward. There is also IBPP, but it is getting quite old now and I am not sure if Firebird 3 is supported.

There is quite good documentation in the $FIREBIRD/doc folder called Using_OO_API.html. The formatting is a little off, but once you get used to the author's style it can take you a long way.

There are also several examples to perform the main functions in $FIREBIRD/interfaces folder.

Btw, why not start with Firebird 4, it's officially released and includes replication.

I have a long term plan to extend wxDatabase to include Firebird 4, but as is often the case just don't have the time at the moment.
wxWidgets 3.1.2, MinGW64 8.1.0, g++ 8.1.0, Ubuntu 19.04, Windows 10, CodeLite + wxCrafter
Some people, when confronted with a GUI problem, think "I know, I'll use Eclipse RCP". Now they have two problems.

Post Reply