Помогите с компиляцией wxCURL испол Topic is solved

Это русская секция форума wxWidjets. В этой секции вы можете обсуждать любые вопросы, связанные с wxWidgets на вашем родном языке.
Post Reply
Chedman
Earned a small fee
Earned a small fee
Posts: 15
Joined: Thu Sep 11, 2008 8:27 am
Contact:

Помогите с компиляцией wxCURL испол

Post by Chedman » Sun Jun 14, 2009 8:12 am

1. Рапаковаыаю wxcurl в корень WXWIN (эта переменная среды определена, как и MINGWDIR)
2. Иду в %WXWIN%\wxcurl\build
3. Создаю build.cmd, там пишу
mingw32-make -f makefile.gcc WX_DEBUG=0 WX_MONOLITHIC=1 WX_USE_OPENGL=1 WX_RUNTIME_LIBS=static WX_USE_RTTI=0 WX_USE_EXCEPTIONS=1 UNICODE=1

wxWidgets-2.8.9 собирал с этими же опциями, проблем не было
4. Стартую build.cmd, а он в ответ
----------------------------------------------------------------------------
The selected wxWidgets build is not available!
Please use the options prefixed with WX_ to select another wxWidgets build.
----------------------------------------------------------------------------

Что не так, помогите?
wxWidgets 2.8, minGW32, CodeBlocks

Chedman
Earned a small fee
Earned a small fee
Posts: 15
Joined: Thu Sep 11, 2008 8:27 am
Contact:

Post by Chedman » Mon Jun 15, 2009 8:17 am

Cделал изменения в build.cmd

mingw32-make -f makefile.gcc WX_DEBUG=0 WX_MONOLITHIC=1 WX_USE_OPENGL=1 WX_RUNTIME_LIBS=static WX_USE_RTTI=0 WX_USE_EXCEPTIONS=1 WX_UNICODE=1

И вижу в конце:
...bin\ld.exe cannot find -l wxmsw28u
collect2: ld returned 1 exit status
mingw32-make: *** [..\samples\protocols\protocols.exe] Error 1
wxWidgets 2.8, minGW32, CodeBlocks

Chedman
Earned a small fee
Earned a small fee
Posts: 15
Joined: Thu Sep 11, 2008 8:27 am
Contact:

Post by Chedman » Mon Jun 15, 2009 12:13 pm

Исправил на
mingw32-make -f makefile.gcc WX_DEBUG=0 WX_MONOLITHIC=0 WX_USE_OPENGL=1 WX_RUNTIME_LIBS=static WX_USE_RTTI=0 WX_USE_EXCEPTIONS=1 WX_UNICODE=1


В %WXWIN%\wxcurl\lib\gcc_lib появился файл libwxcode_msw28u_wxcurl.a,
теперь буду пробывать его, скопировав в %WXWIN%\lib\gcc_lib

Примеры тоже собрались . :)
wxWidgets 2.8, minGW32, CodeBlocks

Post Reply