编译不过 wxDatabaseLayer! Topic is solved

这是wxWidgets论坛的中文版本。在这里,您可以用您的母语汉语讨论上面任一子论坛所涉及的所有关于wxWidgets的话题。欢迎大家参与到对有价值的帖子的中英互译工作中来!
Post Reply
hats
Experienced Solver
Experienced Solver
Posts: 70
Joined: Wed Sep 16, 2009 3:50 pm
Location: China
Contact:

编译不过 wxDatabaseLayer!

Post by hats » Sat Mar 20, 2010 3:10 pm

我想用wx连接数据库,因为2.9.x以上版本不再支持wxDb
所以我想用wxDatabaseLayer.
我的MySQL路径是E:\Program Files\MySQL\MySQL Server 5.0,wx版本是2.8.10
编译器是Code::Blocks自带的gcc3.4.5
我下了1.8版本的源码,修改makefile.gcc 如下

Code: Select all

# Location of MySQL header files 
MYSQL_HEADER_LOCATION ?= E:\Program Files\MySQL\MySQL Server 5.0\include

# Location of MySQL libraries 
MYSQL_LIB_LOCATION ?= E:\Program Files\MySQL\MySQL Server 5.0\lib

# Version of the wx library to build against. 
WX_VERSION ?= 28

# Use monolithic build of wxWidgets? [0,1]
WX_MONOLITHIC ?= 1

我用命令mingw32-make -f makefile.gcc 显示如下图结果
哪位大哥能帮助一下吗?
Attachments
QQ截图未命名.jpg

samsam598
Super wx Problem Solver
Super wx Problem Solver
Posts: 324
Joined: Mon Oct 06, 2008 12:55 pm

Post by samsam598 » Mon Apr 19, 2010 2:32 am

Regards,
Sam
-------------------------------------------------------------------
Windows xp
VS.Net 2003/MinGW 3.4.5 C::B character set: UTF-8
wxWidgets github 3.0 RC1 Unicode Static build,Unicode Shared build.

Post Reply