wxPdfDocument linking problem  [SOLVED]

Talk here about issues with one of the components hosted at wxCode, or suggest features for it.
Myron69
In need of some credit
In need of some credit
Posts: 1
Joined: Mon Sep 11, 2017 7:12 am

wxPdfDocument linking problem

Postby Myron69 » Thu Dec 28, 2017 8:39 am

Hi,

I have a problem building the wxpdfdoc-master on Windows 10 using Visual Studio 2015. I’m using my own monolithic build of wxWidgets-3.1.0 (only x64) and have the following lib files located in C:\wxWidgets-3.1.0\lib\vc_x64_lib:

wxexpat.lib, wxexpatd.lib
wxjpeg.lib, wxjpgd.lib
wxmsw31u.lib, wxmsw31ud.lib
wxpng.lib, wxpngd.lib
wxregexu.lib, wxregexud.lib
wxscintilla.lib, wxscintillad.lib
wxtiff.lib, wxtiffd.lib
wxzlib.lib, wxzlibd.lib

I’m able to successfully build the libraries wxpdfdocd.lib (Debug x64) and wxpdfdoc.lib (Release x64), but I’m not able to build the other projects dcsample, makefont, minimal and showfont.
The error I get is LNK1104 cannot open file ‘wxbase31u.lib’ (release build), which I don’t have in my wxWidgets lib folder.

How do I setup wxpdfdoc and the sample projects to correctly use my wxWidgets libraries?

Best regards,

Myron69

User avatar
doublemax
Moderator
Moderator
Posts: 12822
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxPdfDocument linking problem

Postby doublemax » Thu Dec 28, 2017 9:03 am

Code: Select all

wxbase31u.lib
That's one of the libraries you'd get in a non-monolithic build of wxWidgets. If wxPdfDocument doesn't support that (which i don't know), then just remove the individual library files from the linker settings and add the name of your monolithic library file.
Use the source, Luke!

utelle
Moderator
Moderator
Posts: 830
Joined: Tue Jul 05, 2005 10:00 pm
Location: Cologne, Germany
Contact:

Re: wxPdfDocument linking problem  [SOLVED]

Postby utelle » Thu Dec 28, 2017 12:40 pm

The Visual C++ solutions files coming with wxPdfDocument currently do not support the monolithic build of wxWidgets. AFAIK the same is true for the Visual C++ solution files coming with wxWidgets itself.

Support for the monolithic wxWidgets build is included for gcc and GNU make only.

As doublemax proposed you could adjust the build files to reference just the one monolithic wxWidgets library file.

Regards,

Ulrich


Return to “wxCode”

Who is online

Users browsing this forum: No registered users and 3 guests