Page 1 of 1

[SOLVED]IMule doesn't start with wxGTK2 v3.1.0

Posted: Sun Sep 18, 2016 8:59 am
by pierrotlalune
Hi all,
IMule does not start any more since the upgrade towards Fedora 24 :( .
The terminal shows:
$ imule
2016-09-18 10:44:02: amuleAppCommon.cpp(322): Initialising iMule 2.3.3.3 compiled with wxGTK2 v3.1.0 (Debugging)
2016-09-18 10:44:02: amuleAppCommon.cpp(368): Checking if there is an instance already running...
2016-09-18 10:44:02: amuleAppCommon.cpp(399): No other instances are running.
Assertion failed: ./src/common/sizer.cpp:DoInsert:2082: Assertion '!(flags & wxALIGN_CENTRE_VERTICAL)' failed. Vertical alignment flags are ignored in vertical sizers

Backtrace follows:
[4] wxOnAssert(char const*, int, char const*, char const*, wchar_t const*) in /usr/local/lib/libwx_baseu-3.1.so.0[0x7f327b6ff68e]
[5] wxBoxSizer::DoInsert(unsigned long, wxSizerItem*) in /usr/local/lib/libwx_gtk2u_core-3.1.so.0[0x7f327c1abc86]
[6] muleDlg(wxWindow*, bool, bool) in muuli_wdr.cpp:60
[7] CamuleDlg::CamuleDlg(wxWindow*, wxString const&, wxPoint, wxSize) in amuleDlg.cpp:233
[8] CamuleGuiBase::InitGui(bool, wxString&) in amule-gui.cpp:183
[9] CamuleGuiApp::InitGui(bool, wxString&) in amule-gui.cpp:248
[10] CamuleApp::OnInit() in amule.cpp:564
[11] CamuleGuiApp::OnInit() in amule-gui.cpp:279
[12] wxEntry(int&, wchar_t**) in /usr/local/lib/libwx_baseu-3.1.so.0[0x7f327b788c32]
[13] main in amule-gui.cpp:84
[14] __libc_start_main in /lib64/libc.so.6[0x7f327aa43731]
[15] _start in :0


Aborted (core dumped)
$

I can compile wxWidgets-3.1.0 only.
Please, could you help me to solve ? Thanks.
Sorry for my English, I am a French guy.
Regards.
pll

Re: IMule doesn't start with wxGTK2 v3.1.0

Posted: Sun Sep 18, 2016 9:22 am
by DavidHart
Hi,

Yes, wx3.1 has added several checks for inappropriate sizerflag settings. They should cause asserts rather than anything worse though, and if you tick the 'Don't show this again' box that particular warning won't show again for that IMule instance.

To actually fix it you have two choices:
1) Fix the bug(s). In this case that would mean removing the wxALIGN_CENTRE_VERTICAL sizer flag, which you might find at muuli_wdr.cpp:60. Of course there may be further asserts too...
2) Disable asserts. See NDEBUG in http://wxwidgets.blogspot.com/2009/09/debug-build-changes-in-wx3.html.

Regards,

David

Re: IMule doesn't start with wxGTK2 v3.1.0

Posted: Tue Sep 20, 2016 9:58 pm
by pierrotlalune
Hi David,
I compiled again wxWidgets-3.1.0 without debug mode.
./configure --disable-debug_flag

Now, iMule starts and works.
I thanks you very much.
pll