wxSqlite3 - Building without encryption

Talk here about issues with one of the components hosted at wxCode, or suggest features for it.
lloydkl
In need of some credit
In need of some credit
Posts: 3
Joined: Fri Feb 05, 2016 11:16 am

wxSqlite3 - Building without encryption

Postby lloydkl » Fri Feb 05, 2016 11:28 am

Hi,

I have built wxSqlite3 (3-3.3.0) (dll debug, dll release), using Visual Studio 2010, on Windows 7 , wxWidgets version is 3.0.2

When I start my application it shows an error sqilte3_key not found. I think it is due to my wxSqlite3 is built with encryption support. What is the right way to configure wxSqlite3 without encryption?

Another problem I was facing with build was I was getting the libs (dll and lib) outside a wxSqlite3 folder named ("lib/vc100_dll) I solved it by removing initial "../" from the output path.

Any help is very much appreciated

Thanks,
Lloyd

utelle
Moderator
Moderator
Posts: 741
Joined: Tue Jul 05, 2005 10:00 pm
Location: Cologne, Germany
Contact:

Re: wxSqlite3 - Building without encryption

Postby utelle » Fri Feb 05, 2016 4:02 pm

lloydkl wrote:I have built wxSqlite3 (3-3.3.0) (dll debug, dll release), using Visual Studio 2010, on Windows 7 , wxWidgets version is 3.0.2

When I start my application it shows an error sqilte3_key not found. I think it is due to my wxSqlite3 is built with encryption support. What is the right way to configure wxSqlite3 without encryption?

Encryption support in wxSQLite3 is ruled by a define. Setting the define as follows, deactivates encryption support:

Code: Select all

#define WXSQLITE3_HAVE_CODEC 0

lloydkl wrote:Another problem I was facing with build was I was getting the libs (dll and lib) outside a wxSqlite3 folder named ("lib/vc100_dll) I solved it by removing initial "../" from the output path.

Probably I screwed up the lib path specification. I will check it and fix it in the premake file.

Regards,

Ulrich


Return to “wxCode”

Who is online

Users browsing this forum: No registered users and 1 guest