Build wxFreeChart using Visual Studio

Talk here about issues with one of the components hosted at wxCode, or suggest features for it.
dcorbit
In need of some credit
In need of some credit
Posts: 1
Joined: Tue Dec 22, 2015 8:22 pm

Build wxFreeChart using Visual Studio

Postby dcorbit » Tue Dec 22, 2015 10:30 pm

I was able to build wxWidgets without any problems (batch build of every solution).

But when I try to build wxFreeChart I get errors like this:
1>F:\wxWidgets-3.0.2\include\msvc\wx/setup.h(119): fatal error C1083: Cannot open include file: '../../../lib/vc_dll/mswd/wx/setup.h': No such file or directory

Here is my directory structure for wxWidgets:
Directory of F:\wxWidgets-3.0.2
2015-12-21 10:36 PM <DIR> .
2015-12-21 10:36 PM <DIR> ..
2014-10-06 01:33 PM <DIR> art
2014-10-06 01:34 PM <DIR> build
2014-10-06 01:34 PM <DIR> demos
2014-10-06 01:33 PM <DIR> distrib
2014-10-06 01:34 PM <DIR> docs
2014-10-06 01:33 PM <DIR> include
2014-10-06 01:33 PM <DIR> interface
2015-12-21 10:45 PM <DIR> lib
2014-10-06 01:34 PM <DIR> locale
2014-10-06 01:33 PM <DIR> misc
2014-10-06 01:34 PM <DIR> samples
2014-10-06 01:33 PM <DIR> src
2014-10-06 01:34 PM <DIR> tests
2014-10-06 01:34 PM <DIR> utils

I have environmental variable WXWIN set to:
F:\wxWidgets-3.0.2

I am sure that it is something simple that you experts will know how to fix right away.
What am I doing wrong?

PB
wxWorld Domination!
wxWorld Domination!
Posts: 1202
Joined: Sun Jan 03, 2010 5:45 pm

Re: Build wxFreeChart using Visual Studio

Postby PB » Wed Dec 23, 2015 7:47 am

I assume you built wxWidgets in the default and recommended Unicode mode, i.e. the library files and intermediate folders have "u" in their names, such as %WXWIN%\lib\vc_lib\mswud\wx and wxbase31ud.lib.

AFAIK, wxFreeChart has not been updated for wxWidgets 3 and expects the ANSI build and names of the folders and libraries. You have to change those in the project settings.


Return to “wxCode”

Who is online

Users browsing this forum: No registered users and 1 guest