wxCurl configure is not working under ubuntu ? Topic is solved

Talk here about issues with one of the components hosted at wxCode, or suggest features for it.
Post Reply
Muetdhiver
Super wx Problem Solver
Super wx Problem Solver
Posts: 323
Joined: Sun Jun 08, 2008 11:59 am
Location: Bordeaux, France

wxCurl configure is not working under ubuntu ?

Post by Muetdhiver » Fri Feb 11, 2011 4:36 pm

Hello,

I would like to build and install wxCurl.
The first step after unpacking the wxCurl is to do "./configure".
Here, i've got this error:
checking for curl-config... no
checking whether libcurl is usable... no
configure: error:
Could not find a valid libCURL installation on your system.

If you do not have libCURL installed or you have an old version
then please install the latest version from
http://curl.haxx.se/libcurl/

If you have a valid libCURL installed, then please check the config.log
file for more details about the failure of this check.
That is very sad because I've got libcurl3 installed as an ubuntu package:
/usr/lib/libcurl-gnutls.so.3
/usr/lib/libcurl-gnutls.so.4
/usr/lib/libcurl-gnutls.so.4.2.0
/usr/lib/libcurl.so.3
/usr/lib/libcurl.so.4
/usr/lib/libcurl.so.4.2.0
....
And I also tried:

Code: Select all

./configure --with-libcurl=/usr/lib
but this was not working :
checking for curl-config... /usr/lib/bin
checking for the version of libcurl... ./configure: line 4359: /usr/lib/bin: No such file or directory

checking for libcurl >= version 7.15.0... no
configure: error:
.....
Do yu have an idea or it is just that wxcurl is not maintained anymore and configure script is rotten ? .....

Thanks.
Alexandre.
OS: Ubuntu 11.10
Compiler: g++ 4.6.1 (Eclipse CDT Indigo)
wxWidgets: 2.9.3

qgranfor
Experienced Solver
Experienced Solver
Posts: 89
Joined: Sun Aug 29, 2004 7:32 pm
Location: ND...USA
Contact:

Post by qgranfor » Sat Feb 12, 2011 9:17 pm

You need to have the curl-dev installed as well to build against.

Muetdhiver
Super wx Problem Solver
Super wx Problem Solver
Posts: 323
Joined: Sun Jun 08, 2008 11:59 am
Location: Bordeaux, France

Post by Muetdhiver » Thu Feb 24, 2011 8:59 am

Hi !!
I added this package: libcurl4-ssl-dev and the configure run well !!!
Thanks for your help.

Bye.
OS: Ubuntu 11.10
Compiler: g++ 4.6.1 (Eclipse CDT Indigo)
wxWidgets: 2.9.3

Post Reply