install wxWidgets - wxGTK-2.8.7

This forum is reserved for everything you want to talk about. It could be about programming, opinions, open source programs, development in general, or just cool stuff to share!
Post Reply
ruidias
Earned a small fee
Earned a small fee
Posts: 13
Joined: Tue Jun 17, 2008 2:38 pm

install wxWidgets - wxGTK-2.8.7

Post by ruidias » Tue Jun 17, 2008 2:42 pm

Hello,

I'm trying to install wxWidgets (wxGTK-2.8.7) in my system.
Before I had installed the wxX11-2.8.7 with success but it was the wrong installation, the system hang all the time.

When i switch to wxGTK, after running the ./configure --with-gtk to install the package, the following error occurs:

checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.



I think that I have the right GTK and all the other dependencies, e.g, with the following command i get:

rpm -qa | grep gtk
pygtk2-libglade-2.10.1-8.el5
authconfig-gtk-5.3.12-2.el5
gtk2-engines-2.8.0-3.el5
gtkspell-2.0.11-2.1
gnome-python2-gtkhtml2-2.14.2-4.fc6
gtk2-2.10.4-16.el5
gtk2-engines-2.8.0-3.el5
usermode-gtk-1.88-3.el5
gtksourceview-1.8.0-1.fc6
gtkhtml3-3.12.0-1.fc6
gnome-python2-gtksourceview-2.16.0-1.fc6
gtk2-2.10.4-16.el5
pygtk2-2.10.1-8.el5
gtkspell-2.0.11-2.1
gtkhtml3-3.12.0-1.fc6
scim-bridge-gtk-0.4.5-7.el5
libswt3-gtk2-3.2.1-18.el5
scim-bridge-gtk-0.4.5-7.el5
libgtk-java-2.8.7-3.el5
gtkhtml2-2.11.0-3

rpm -qa | grep glib
glib2-2.12.3-2.fc6
avahi-glib-0.6.16-1.el5
NetworkManager-glib-0.6.4-6.el5
glibc-headers-2.5-12
compat-glibc-headers-2.3.4-2.26
glib2-devel-2.12.3-2.fc6
glibc-2.5-12
dbus-glib-0.70-5
glibc-devel-2.5-12
glibc-common-2.5-12
dbus-glib-0.70-5
glib2-2.12.3-2.fc6
avahi-glib-0.6.16-1.el5
glibc-devel-2.5-12
compat-glibc-2.3.4-2.26
glibc-2.5-12
glib-java-0.2.6-3.fc6
compat-glibc-2.3.4-2.26
NetworkManager-glib-0.6.4-6.el5

rpm -qa | grep atk
atk-1.12.2-1.fc6
atk-1.12.2-1.fc6

rpm -qa | grep pango
pango-1.14.9-3.el5
pango-1.14.9-3.el5

rpm -qa | grep cairo
cairo-1.2.4-1.fc6
cairo-1.2.4-1.fc6
cairo-java-1.0.5-3.fc6
pycairo-1.2.0-1.1


Does anyone knows what is wrong?


thanks a lot for your time.

Rui

User avatar
doublemax
Moderator
Moderator
Posts: 14874
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Post by doublemax » Tue Jun 17, 2008 2:59 pm

i'm not a linux expert, but i think you're (at least) missing the gtk2-devel package.
Use the source, Luke!

qgranfor
Experienced Solver
Experienced Solver
Posts: 89
Joined: Sun Aug 29, 2004 7:32 pm
Location: ND...USA
Contact:

Post by qgranfor » Tue Jun 17, 2008 5:31 pm

Looks like you have GTK2 installed, but not the corresponding GTK2 development files.

ennogir
Earned a small fee
Earned a small fee
Posts: 14
Joined: Tue Oct 21, 2008 11:39 am

Post by ennogir » Thu Nov 20, 2008 9:31 am

the same thing happens to me! can anyone find a solution?? thanks a lot!

DavidHart
Site Admin
Site Admin
Posts: 3980
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Post by DavidHart » Thu Nov 20, 2008 10:54 am

Hi,

As everyone already said, the OP was missing the gtk2 development package, which tends to be called gtk2-devel* or libgtk2.0-dev or similar, depending on distro.

If you have the same problem, installing that package is the solution.

Regards,

David

dcrocker
Knows some wx things
Knows some wx things
Posts: 28
Joined: Mon Sep 26, 2011 7:53 am

Re: install wxWidgets - wxGTK-2.8.7

Post by dcrocker » Tue Mar 06, 2012 10:31 am

I'm having the same problem, trying to build wGTK-2.8.12 under Ubuntu 9.04. When i try to install libgtk2.0-dev via apt-get, it reports:

>>
Package libgtk2.0-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libgtk2.0-bin
<<

If I try to update libgtk2.0-bin then it reports that I already have the latest version. Any ideas?

dcrocker
Knows some wx things
Knows some wx things
Posts: 28
Joined: Mon Sep 26, 2011 7:53 am

Re: install wxWidgets - wxGTK-2.8.7

Post by dcrocker » Tue Mar 06, 2012 11:25 am

I managed to resolve the problem by editing /etc/apt/sources.conf to change some URLs and uncomment others, to make libgtk2.0-dev available for installation..

User avatar
xaviou
Super wx Problem Solver
Super wx Problem Solver
Posts: 429
Joined: Mon Aug 21, 2006 3:18 pm
Location: Annecy - France
Contact:

Re: install wxWidgets - wxGTK-2.8.7

Post by xaviou » Tue Mar 06, 2012 4:45 pm

Hi
dcrocker wrote:If I try to update libgtk2.0-bin then it reports that I already have the latest version. Any ideas?
You need the devel package of libgtk : it's something like "libgtk2.0-dev"

Regards
Xav'
My wxWidgets stuff web page : [email protected]'s wxStuff

Post Reply