Page 1 of 1

wxPdfDoc DevPack doesn't work

Posted: Thu Jul 13, 2017 11:43 am
by Vivendus82
I downoalded the wxPdfDoc DevPack for wxDevC++.
All headers and library are included in my project. When I build it it goes almost through out all the process but in the end I get several warning messages and strange errors about missing reference to wxString and so on.

Can anybody help me?

Thanks

Re: wxPdfDoc DevPack doesn't work

Posted: Thu Jul 13, 2017 1:59 pm
by ONEEYEMAN
Hi,
What is an exact error message you get? What warnings?
What are the wxWidgets version you are building against?
What is your OS/toolkit and their versions?
What version of wxPdfDoc you are trying?

Thank you.

Re: wxPdfDoc DevPack doesn't work

Posted: Fri Jul 14, 2017 6:37 am
by utelle
AFAIK wxDevC++ is rather outdated, and even more so the wxPdfDoc DevPack ( over 10 years old version 0.8 ).

I would strongly recommend to use a more up-to-date IDE like Code::Blocks, CodeLite, or Visual Studio (Community edition) together with recent versions of wxWidgets and wxPdfDocument.

Regards,

Ulrich

Re: wxPdfDoc DevPack doesn't work

Posted: Fri Jul 14, 2017 5:18 pm
by Vivendus82
Hi,

I have wxWidgets 2.9.5 and wxPdfDoc 1.0 running on Windows 10.

I attach a screenshot of the compiler output.

Thank you.

PS: Anyway I think I will try Qt for my next projects. It seems more reliable.

Re: wxPdfDoc DevPack doesn't work

Posted: Sat Jul 15, 2017 6:24 am
by utelle
Vivendus82 wrote:I have wxWidgets 2.9.5 and wxPdfDoc 1.0 running on Windows 10.
There is no such version as wxPdfDoc 1.0 - the most recent wxPdfDocument version is 0.9.6. So I assume that version 1.0 is the version of the DevPack. If you just tried to use the wxPdfDoc DevPack as provided on the wxDev-C++ webpage, then you are using wxPdfDocument version 0.8 (which is over 10 years old).
Vivendus82 wrote:I attach a screenshot of the compiler output.
The screenshot is not very helpful since the messages are truncated. However, my guess is that you are mixing different wxWidgets versions. You wrote that you are using wxWidgets 0.9.5 (which was released in 2013 if I remember correctly), but the wxPdfDoc DevPack was released in 2011 - that is, it was certainly not build against wxWidgets 2.9.5.

Trying to link components that were compiled against different versions of wxWidgets will almost for sure result in strange messages and errors.

You should compile wxPdfDocument yourself, instead of using the outdated pre-compiled DevPack.
Vivendus82 wrote:PS: Anyway I think I will try Qt for my next projects. It seems more reliable.
Well, in fact you can't blame wxWidgets for the problems you experience, if you stick to outdated tools and components. You would run into similar troubles with Qt if you would try to combine components compiled against different Qt versions.

Regards,

Ulrich

Re: wxPdfDoc DevPack doesn't work

Posted: Sun Jul 16, 2017 6:30 pm
by Vivendus82
Hi,
Whatever you think I did, I didn't do it on purpose. I just downoaded what the wxDev server had, and it didn't work. I already tried to compile wxpdf on my own and didn't work either. I don't care anymore. I'm not a pro, I just write small application for education.
I'm using Qt and I'm not mixing anything wrong, and I managed to do what I wanted. I think wxDevC++ is still very good, just, as you said, not really up to date.

Thank you anyway for the support,

Best regards.

Re: wxPdfDoc DevPack doesn't work

Posted: Sun Jul 16, 2017 7:33 pm
by ONEEYEMAN
Hi,
I hope you care enough for other people that do you wx and wxPdfDoc. So could you please provide more info.

You said that you tried to compile the latest wxPdfDoc and it failed compilation.
Could you please answer couple of simple questions:

You are running Windows 10.
You were using wxWidgets 2.9.5.
I presume you were using some flavor of gcc (MinGW, TDM-GCC) Could you tell us which one and which version?
I would guess that it did come with wxDev-C++, but as Ulrich said it is really outdated and it does not developed anymore AFAIK. So you probably should get that info from the Terminal/Command Prompt.
I also I presume that wxWidgets-2.9.5 was compiled successfully - i.e. without any errors with that compiler.
The errors you were inquiring are from compiling wxPdfDoc and not from wxWidgets itself.
Now I'm curious - what errors did you get trying to compile recent wxPdfDoc (not the DevPack one you downloaded with wxDev-C++).

I understand that you probably remove everything already and you don't remember this. In this case - we are sorry that this didn't work for you and we wish you good luck in you future development needs.
But if you have a spare time please try to reproduce the failure you had with wxPdfDoc latest version. It will help - at the very least Ulrich will fix the build so that the next person won't have a failure.

Thank you.

P.S.: Also, please understand - nobody tried to accuse you of anything. Ulrich just simply pointed out that you were using a really outdated software and the maintainer(s) for it are either disappear or don't care anymore since there are much more and much better IDEs. Unfortunately as you probably know the IDE selection are personal preferences.