wxdevc++ dialogs disappear

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
michael999
In need of some credit
In need of some credit
Posts: 8
Joined: Mon Jun 15, 2015 11:00 pm

wxdevc++ dialogs disappear

Postby michael999 » Mon Jun 15, 2015 11:19 pm

Hey guys, i am new here, and I try to understand project development with wxdevc++.
My version is 7.4.2.569 bs windows 8.
I am working with the book "Programming with wxDev++",
and i am busy with the HTMLEdit project.
So far so good.
But the integrated dialogs disappear next project loading.
I integrated them again with the project inspector or built new,
then it worked, next time loading, not to find.
I like the work with the ide, but it is frustrating.
Thanks a lot, if anybody knows what to do. :)
Greets Michael

michael999
In need of some credit
In need of some credit
Posts: 8
Joined: Mon Jun 15, 2015 11:00 pm

Re: wxdevc++ dialogs disappear, ide does not work anymore

Postby michael999 » Wed Jun 17, 2015 10:04 pm

After re adding the dialogs with "project -> add", the dialogs are still there,
that i could continue the work .
At last, i had a run time error, since that, ide had process (access) violations
every time loading any project (ofcourse i switched off the computer between).
And now ide doesn' t work anymore. :(
Should I reinstall ? Other ideas ?
Thx Michael

jgrzybowski
Earned some good credits
Earned some good credits
Posts: 103
Joined: Sat Sep 24, 2011 9:32 pm
Location: Poland

Re: wxdevc++ dialogs disappear

Postby jgrzybowski » Thu Jun 18, 2015 8:24 pm

Mayby you can try to use older version. I still use 7.3.1 version. I have started to use 7.3.1 on Windows XP. Now I am still running 7.3.1 on Windows 8.1, generaly with out any bigger troubles. Of coures my projects are quite small programms. Good luck. Regards, Jarek

michael999
In need of some credit
In need of some credit
Posts: 8
Joined: Mon Jun 15, 2015 11:00 pm

Re: wxdevc++ dialogs disappear

Postby michael999 » Thu Jun 18, 2015 8:56 pm

Good Idea.I reinstalled the actual version, the same problems,
every project, access violation.
I tried code:blocks, but it doesnt work with wxwidget lib,
i would have to compile the sources of them,someone wrote.
Its hard to find an easy and good running system, i think.
Many thanks for your answer.
Michael :)

jgrzybowski
Earned some good credits
Earned some good credits
Posts: 103
Joined: Sat Sep 24, 2011 9:32 pm
Location: Poland

Re: wxdevc++ dialogs disappear

Postby jgrzybowski » Fri Jun 19, 2015 7:47 pm

Some people use Code::Blocks with wxWidget (manaully installed) and wxSmith plugin (this is RAD designer for forms and dialogs). More info in other subforums for example "Compiler / Linking / IDE Related". Regards, Jarek

michael999
In need of some credit
In need of some credit
Posts: 8
Joined: Mon Jun 15, 2015 11:00 pm

Re: wxdevc++ dialogs disappear

Postby michael999 » Fri Jun 19, 2015 8:43 pm

Yes, thanks.
I think i have no other chance to try it with code::blocks, wxdevc++ 7.3.1 does not work too.
I tried code::blocks with manually wxwidgets binary libs, so the message appeared
"a matching release configuration cannot be found in the wxWidget directory".
With the complete message I found a code::blocks forum entry,
which means that it doent work with the binary libs, so i would have to load the source code
and compile it with special flags.

Is it this, you meant?:
viewtopic.php?f=19&t=40437

Greets Michael

jgrzybowski
Earned some good credits
Earned some good credits
Posts: 103
Joined: Sat Sep 24, 2011 9:32 pm
Location: Poland

Re: wxdevc++ dialogs disappear

Postby jgrzybowski » Sat Jun 20, 2015 10:53 pm

Yes, you have found correct topic.
wxDevC++ 7.3.1.3 for sure works fine even on windows 8.1. Something is wrong installed or you have not removed all from previous installation. Try to install via full installer from here:
http://sourceforge.net/projects/wxdsgn/files/wxDev-C%2B%2B/Version%207/
Regards, Jarek

michael999
In need of some credit
In need of some credit
Posts: 8
Joined: Mon Jun 15, 2015 11:00 pm

Re: wxdevc++ dialogs disappear

Postby michael999 » Sat Jun 20, 2015 11:17 pm

Thank you Jarek, I downloaded the full installer, you advised.
I think too, there are some rests of the old installation,
because i tried to load a simple project, and it failed the same way.
But I used the official deinstallation, and the folder was clear.
Meanwhile I got code::form to run with wxwidgets, after more than 90 min compiling (lame duck laptop?).
:D
I could create a little frame with buttons, but I need the custom gcc dll in the release
folder.Static lib does not work, i think i have to compile again with another shared flag?
OK, its late now.

Good night
Michael


Return to “wxDev-C++”

Who is online

Users browsing this forum: No registered users and 3 guests