Panels not being displayed: Project inspector, Compiler etc

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
Post Reply
softport
Experienced Solver
Experienced Solver
Posts: 61
Joined: Sat Jan 28, 2012 3:55 pm
Location: Houston TX
Contact:

Panels not being displayed: Project inspector, Compiler etc

Post by softport » Wed Mar 20, 2013 2:43 am

Hello, sorry to bug you all again, but the IDE has more problems: It will not display (or I can't figure out how) any panels.

In View->Show panels I can check and un-check the panel selection, but it makes no difference, nothing happens.
Instead, 2 drop boxes have appeared where I can select a class (in the left one), and a member function in the second one.
Not all project files are available in the selections, which makes it impossible to bring them up in the IDE and modify.

(Edit) Correction, you can do File->Load and display any project file. Also, if someone might be wondering, when trying to open a panel it's not the case that the edit window just needs to be moved out of the way, I tried that. When trying to open the project manager panel you can see the edit window twitch to the right about a mm, but nothing else happens.

Image

I think it's begging me to be re-installed, but I can't figure out how. There does not seem to be an entry for DEV-C++ in the add/remove programs, and there is no uninstall exe in the DEV-C++ directory (that I can find). I know I have done this before, so I just can't remember (probably due to the frustration at this point).

Other problems (minor) are that the tools and properties panels have become un-docked, and the IDE will not allow me to dock them again on the right hand side (although they can be docked at the top).

Update: never mind, I just saved the projects folder, deleted the DEV-Cpp folder and ran CC Cleaner to clean up the registry.
I'm installing a fresh copy.
Windows XP, wxDev-C++ 7.4.2.259, wxWidgets 2.8.12, MingW

tbreina
Moderator
Moderator
Posts: 1289
Joined: Thu Nov 25, 2004 7:38 pm
Location: Coronado, CA

Re: Panels not being displayed: Project inspector, Compiler

Post by tbreina » Mon Apr 01, 2013 4:18 pm

Usually you don't need to re-install. You can simply look for the file devcpp.ini and delete it. That will cause the program to re-create all of the default settings when it is started again.

-Tony
Everybody's got something to hide except for me and my monkey.

softport
Experienced Solver
Experienced Solver
Posts: 61
Joined: Sat Jan 28, 2012 3:55 pm
Location: Houston TX
Contact:

Re: Panels not being displayed: Project inspector, Compiler

Post by softport » Sat Apr 06, 2013 7:30 am

Thanks Tony, I'll keep that in mind for next time. It's been an interesting week trying out new things. Had a go at Visual C++ 2008 and was extremely impressed with how easy it was to make a GUI. Then the problems start (if you are only familiar with C and C++) when writing the code behind it: "Error: can't call unmanaged function from managed code!". What the heck. Great way to turn something great, into something not worth the trouble. Maybe that should be the Microsoft slogan.
Windows XP, wxDev-C++ 7.4.2.259, wxWidgets 2.8.12, MingW

Post Reply