7.4.2.569 Many "duplicate section" warnings when compiling Topic is solved

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
Post Reply
softport
Experienced Solver
Experienced Solver
Posts: 61
Joined: Sat Jan 28, 2012 3:55 pm
Location: Houston TX
Contact:

7.4.2.569 Many "duplicate section" warnings when compiling

Post by softport » Tue Sep 25, 2012 11:06 pm

Hello, I just upgraded wxDecC++ from 7.4.1.13 to 7.4.2.569. When I try to compile/link my old code, written with version 7.4.1.13 I get a long list of warnings like these:

[Warning] duplicate section `.rdata$_ZTV20wxThreadHelperThread[vtable for wxThreadHelperThread]' has different size
[Warning] duplicate section `.rdata$_ZTI12wxEvtHandler[typeinfo for wxEvtHandler]' has different size

Before upgrading I uninstalled wxDev++ with the uninstaller, did not erase the Dev-cpp folder, did a web install of the new version. Should I have erased the Dev-cpp folder first?
...
I just tried writing a simple program, that has one button, and it compiled and ran with no problems. How can I make my older programs compile and run in version 7.4.2.569? I have a feeling this is not possible without making a new project, remaking the old "wxForm", and copying/pasting the rest of the old code into the new project. :(

Thanks!

Update
In Tools->Compiler options->WxWidgets it says version 2.9.3
For my old code I need 2.8.12 . If I change the compiler option to wxWidgets 2.8.12, then I get a compilation error saying it can't find lwxmsw28u and lwxmsw28u_gl.

Now, blundering away... in Package Manager I found lwxmsw29u and lwxmsw29u_gl inside "WxWidgets Mingw gcc"
version 2.9.3.5 . I tried using "check for updates" to find an earlier version of WxWidgets Mingw gcc package with no success. Is this actually what I need to do to get my wxWidgets (version 2.8.12) to work? Find the package WxWidgets Mingw gcc (version 2.8.x)?
Windows XP, wxDev-C++ 7.4.2.259, wxWidgets 2.8.12, MingW

alancan
Earned a small fee
Earned a small fee
Posts: 21
Joined: Mon Jul 26, 2010 1:35 pm

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by alancan » Thu Sep 27, 2012 6:36 pm

@softport,

I have been working on this same issue on/off for a month now, any luck so far?

I have attempted to reinstall multiple times; including installing directly to C:/Dev-cpp to avoid the space in "Program Files", turned on unicode support, and updating the library to be lwxmsw29u and 29u_gl, and have made changes to code to reflect the update in wxwidgets 2.9.3 (was running with 2.8.x previously)

funny thing is, the program compiles and runs properly, yet these warnings persist, and are of concern.

I have found these other posts with similar stories.

http://forums.wxwidgets.org/viewtopic.php?f=19&t=32048
http://forums.wxwidgets.org/viewtopic.php?f=28&t=33022

I believe you can revert back to older versions of wxWidgets, though I am unsure of the methods involved here - a search of the forums may produce some results.

** will update if I find the solution myself

softport
Experienced Solver
Experienced Solver
Posts: 61
Joined: Sat Jan 28, 2012 3:55 pm
Location: Houston TX
Contact:

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by softport » Thu Sep 27, 2012 9:06 pm

Hi Alan, no solution yet. Have to admit that I almost gave up and started watching videos from "thenewbostonian"
on QT. Something about wxWidgets though makes you want to stick with it.

I'll keep looking for an earlier version of the "WxWidgets Mingw gcc" package. Not hoping for much even if I find it though. One project has several displays, all with custom colors and each with it's own spin button, set up on multiple layers of grid sizers. Really don't look forward to redoing all that. I just tried running it in the IDE and got this new error while linking, or maybe just after as it started to run:

"[New Thread 2448.0xbe0]\n"
Stopped - signal received
Thread 1 stopped in Display::~Display() at line 5808667 in with Segmentation fault
Debugger closed.

I think we are toast! Oh well. Hope you come up with something.

waltercan't
Windows XP, wxDev-C++ 7.4.2.259, wxWidgets 2.8.12, MingW

tbreina
Moderator
Moderator
Posts: 1289
Joined: Thu Nov 25, 2004 7:38 pm
Location: Coronado, CA

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by tbreina » Fri Sep 28, 2012 9:02 pm

softport wrote: Update
In Tools->Compiler options->WxWidgets it says version 2.9.3
For my old code I need 2.8.12 . If I change the compiler option to wxWidgets 2.8.12, then I get a compilation error saying it can't find lwxmsw28u and lwxmsw28u_gl.

Now, blundering away... in Package Manager I found lwxmsw29u and lwxmsw29u_gl inside "WxWidgets Mingw gcc"
version 2.9.3.5 . I tried using "check for updates" to find an earlier version of WxWidgets Mingw gcc package with no success. Is this actually what I need to do to get my wxWidgets (version 2.8.12) to work? Find the package WxWidgets Mingw gcc (version 2.8.x)?
Go to Tools->Compiler Options and click on the tab for "wxWidgets". You'll need to change it for wxWidgets 2.9.3 Unicode, Monolithic, static import library. You'll only need to do this once.

Now for each of your old projects, go to: Project->Project Options. In the parameters tab, make sure that

Preprocessor Definitions =
__WXMSW__
__GNUWIN32__
_UNICODE

and

Linker options =
-mwindows
-l$(WXLIBNAME)
-l$(WXLIBNAME)_gl
-lwxscintilla
-lwxtiff
-lwxjpeg
-lwxpng
-lwxzlib
-lwxregexu
-lwxexpat
-lkernel32
-luser32
-lgdi32
-lcomdlg32
-lwinspool
-lwinmm
-lshell32
-lcomctl32
-lole32
-loleaut32
-luuid
-lrpcrt4
-ladvapi32
-lwsock32
-lodbc32
-lopengl32

for the MinGW gcc compiler.

For MS VC++,

Preprocessor should be empty.
Compiler/C++ Compiler should be: /MD
Linker =
$(WXLIBNAME).lib
$(WXLIBNAME)_gl.lib
wxscintilla.lib
wxtiff.lib
wxjpeg.lib
wxpng.lib
wxzlib.lib
wxregexu.lib
wxexpat.lib
kernel32.lib
user32.lib
gdi32.lib
comdlg32.lib
winspool.lib
winmm.lib
shell32.lib
comctl32.lib
ole32.lib
oleaut32.lib
uuid.lib
rpcrt4.lib
advapi32.lib
wsock32.lib
odbc32.lib
opengl32.lib

Finally, you'll need to do a rebuild all.

-Tony
Everybody's got something to hide except for me and my monkey.

softport
Experienced Solver
Experienced Solver
Posts: 61
Joined: Sat Jan 28, 2012 3:55 pm
Location: Houston TX
Contact:

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by softport » Sat Sep 29, 2012 3:53 pm

tbreina wrote:
Go to Tools->Compiler Options and click on the tab for "wxWidgets". You'll need to change it for wxWidgets 2.9.3 Unicode, Monolithic, static import library. You'll only need to do this once.

Now for each of your old projects, go to: Project->Project Options. In the parameters tab, make sure that

Preprocessor Definitions =
__WXMSW__
__GNUWIN32__
_UNICODE


and

Linker options =
-mwindows
-l$(WXLIBNAME)
-l$(WXLIBNAME)_gl

-lwxscintilla
-lwxtiff
-lwxjpeg
-lwxpng
-lwxzlib
-lwxregexu
-lwxexpat
-lkernel32
-luser32
-lgdi32
-lcomdlg32
-lwinspool
-lwinmm
-lshell32
-lcomctl32
-lole32
-loleaut32
-luuid
-lrpcrt4
-ladvapi32
-lwsock32
-lodbc32
-lopengl32


for the MinGW gcc compiler.

Finally, you'll need to do a rebuild all.

-Tony
=D> Thanks Tony!
In the quote above I highlighted, in green, the parts that were ok, and in red the parts that I changed.
Out of curiosity I also tried just "Rebuild all" without making any changes, and that worked! So all this time
I just forgot/didn't know about having to rebuild all.

The include library: -lwxscintilla doesn't seem to make any difference whether it's there or not, but I put it
in there. Hope this works for alancan a well.

Thanks again,

Walter
Windows XP, wxDev-C++ 7.4.2.259, wxWidgets 2.8.12, MingW

tbreina
Moderator
Moderator
Posts: 1289
Joined: Thu Nov 25, 2004 7:38 pm
Location: Coronado, CA

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by tbreina » Sat Sep 29, 2012 6:12 pm

Ahh, yes that makes sense. Rebuild All is definitely your friend when things go wrong. Basically, GNU make doesn't always realize what files it needs to re-compile. So what probably happened was it was trying to link parts of your project that were compiled and linked against wxWidgets 2.8.12 with the new 2.9.3. That's what caused all of the duplicate sections.

-Tony
Everybody's got something to hide except for me and my monkey.

alancan
Earned a small fee
Earned a small fee
Posts: 21
Joined: Mon Jul 26, 2010 1:35 pm

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by alancan » Tue Oct 30, 2012 8:08 pm

I have followed all of these procedures previously without luck, except for the Rebuild All. Well, clarification, I did attempt the Rebuild All, however it failed:

Code: Select all

del: not found
mingw32-make.exe: *** [clean] Error 127

Execution terminated
Compilation Failed. Make returned 2
So I am investigating this issue, with no luck so far. Looks like it is having trouble with the del command.

Any tips on this will be much appreciated.

Once again, my programs do compile, it is more of a nuisance than anything right now.

-Alan

PB
Part Of The Furniture
Part Of The Furniture
Posts: 2463
Joined: Sun Jan 03, 2010 5:45 pm

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by PB » Wed Oct 31, 2012 4:16 pm

IIRC I had the same issue with GCC (del not found) when I got another compiler related stuff in the PATH environment variable (it was msys for me).

alancan
Earned a small fee
Earned a small fee
Posts: 21
Joined: Mon Jul 26, 2010 1:35 pm

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by alancan » Thu Nov 01, 2012 1:52 pm

PB, thanks for this, I am successfully able to do a "Rebuild All" and a "Clean" now, (Removed path to RTools (which contains it's own instance of gcc if that matters), fixed that for me).

This has solved my warning output problem, appreciate the help from all!

-Alan

robertoforlin
In need of some credit
In need of some credit
Posts: 1
Joined: Wed Feb 22, 2012 8:50 pm

Re: 7.4.2.569 Many "duplicate section" warnings when compili

Post by robertoforlin » Wed Nov 21, 2012 7:49 pm

Hi guys,
I have the same problem but my project was developed with wxdevc++ 7.3.1.
I followed all the advices posted in this forum but the problem remains.
Please help me!

Post Reply