Page 1 of 1

empty template project and "cannot find -lwxmsw" e

Posted: Tue Jul 07, 2009 12:32 am
by sds
Hi,

this is my first post here.

I installed wxDevC++ yesterday because I wanted a better GUI for a game I am programming. The code is based on Allegro and didnt compile since I changed from DevC++ to wxDevC++ and Allegro version 4.0 to 4.2 (but that is not why I am writing here).

1. wxDevC++ creates an empty template project

2. examples do not compile: "cannot find -lwxmsw" error message.

Thanks in advance for any advice!

Re: empty template project and "cannot find -lwxmsw&quo

Posted: Tue Jul 07, 2009 2:05 am
by tbreina
sds wrote: 2. examples do not compile: "cannot find -lwxmsw" error message.
That's probably my fault.

Go to Project->Project Options->Parameters and change the -lwxmsw to -lwxmsw28.

-Tony

Re: empty template project and "cannot find -lwxmsw&

Posted: Tue Jul 07, 2009 2:54 am
by sds
tbreina wrote:
sds wrote: 2. examples do not compile: "cannot find -lwxmsw" error message.
That's probably my fault.

Go to Project->Project Options->Parameters and change the -lwxmsw to -lwxmsw28.

-Tony
Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".

Re: empty template project and "cannot find -lwxmsw&

Posted: Tue Jul 07, 2009 5:04 am
by tbreina
sds wrote: Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".
-lwxmsw28_gl

Posted: Tue Jul 07, 2009 8:20 am
by Sof_T
I'm sure you have got the pattern by now, for any of the -lwxmsw files it can't find add a 28 in there :D

Re: empty template project and "cannot find -lwxmsw&

Posted: Tue Jul 07, 2009 9:13 am
by sds
tbreina wrote:
sds wrote: Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".
-lwxmsw28_gl
Thanks that made the examples compile and run happily!

Posted: Tue Jul 07, 2009 9:20 am
by sds
And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...

Posted: Tue Jul 07, 2009 9:31 am
by sds
Sof_T wrote:I'm sure you have got the pattern by now, for any of the -lwxmsw files it can't find add a 28 in there :D
I didnt pass the idiot test... I already tried "-lwxmsw_gl28"...

Posted: Tue Jul 07, 2009 12:46 pm
by Sof_T
sds wrote:And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...
The empty template just creates a project with the correct library paths, etc for using the wxWidgets libraries. You have to add all the code. So that is quite normal.

Posted: Tue Jul 07, 2009 1:50 pm
by sds
Sof_T wrote:
sds wrote:And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...
The empty template just creates a project with the correct library paths, etc for using the wxWidgets libraries. You have to add all the code. So that is quite normal.
Thanks, then everythink seems to be working now. The Allegro Pack was running right from the start.