empty template project and "cannot find -lwxmsw" e Topic is solved

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
Post Reply
sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

empty template project and "cannot find -lwxmsw" e

Post by sds » Tue Jul 07, 2009 12:32 am

Hi,

this is my first post here.

I installed wxDevC++ yesterday because I wanted a better GUI for a game I am programming. The code is based on Allegro and didnt compile since I changed from DevC++ to wxDevC++ and Allegro version 4.0 to 4.2 (but that is not why I am writing here).

1. wxDevC++ creates an empty template project

2. examples do not compile: "cannot find -lwxmsw" error message.

Thanks in advance for any advice!
Stefan Schmollack http://schmollack.net/

tbreina
Moderator
Moderator
Posts: 1289
Joined: Thu Nov 25, 2004 7:38 pm
Location: Coronado, CA

Re: empty template project and "cannot find -lwxmsw&quo

Post by tbreina » Tue Jul 07, 2009 2:05 am

sds wrote: 2. examples do not compile: "cannot find -lwxmsw" error message.
That's probably my fault.

Go to Project->Project Options->Parameters and change the -lwxmsw to -lwxmsw28.

-Tony
Everybody's got something to hide except for me and my monkey.

sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

Re: empty template project and "cannot find -lwxmsw&

Post by sds » Tue Jul 07, 2009 2:54 am

tbreina wrote:
sds wrote: 2. examples do not compile: "cannot find -lwxmsw" error message.
That's probably my fault.

Go to Project->Project Options->Parameters and change the -lwxmsw to -lwxmsw28.

-Tony
Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".
Stefan Schmollack http://schmollack.net/

tbreina
Moderator
Moderator
Posts: 1289
Joined: Thu Nov 25, 2004 7:38 pm
Location: Coronado, CA

Re: empty template project and "cannot find -lwxmsw&

Post by tbreina » Tue Jul 07, 2009 5:04 am

sds wrote: Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".
-lwxmsw28_gl
Everybody's got something to hide except for me and my monkey.

Sof_T
Can't get richer than this
Can't get richer than this
Posts: 864
Joined: Thu Jul 28, 2005 9:48 pm
Location: New Forest, United Kingdom
Contact:

Post by Sof_T » Tue Jul 07, 2009 8:20 am

I'm sure you have got the pattern by now, for any of the -lwxmsw files it can't find add a 28 in there :D
The home of Sof.T http://www.sof-t.site88.net/
Author of Programming with wxDevC++
http://sourceforge.net/projects/wxdevcpp-book/

sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

Re: empty template project and "cannot find -lwxmsw&

Post by sds » Tue Jul 07, 2009 9:13 am

tbreina wrote:
sds wrote: Thanks for your answer.

I did what you said and then I tried to compile "anitest" (animation), I got this error message: "cannot find -lwxmsw_gl".
-lwxmsw28_gl
Thanks that made the examples compile and run happily!
Last edited by sds on Tue Jul 07, 2009 9:30 am, edited 1 time in total.
Stefan Schmollack http://schmollack.net/

sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

Post by sds » Tue Jul 07, 2009 9:20 am

And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...
Last edited by sds on Tue Jul 07, 2009 9:40 am, edited 1 time in total.
Stefan Schmollack http://schmollack.net/

sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

Post by sds » Tue Jul 07, 2009 9:31 am

Sof_T wrote:I'm sure you have got the pattern by now, for any of the -lwxmsw files it can't find add a 28 in there :D
I didnt pass the idiot test... I already tried "-lwxmsw_gl28"...
Stefan Schmollack http://schmollack.net/

Sof_T
Can't get richer than this
Can't get richer than this
Posts: 864
Joined: Thu Jul 28, 2005 9:48 pm
Location: New Forest, United Kingdom
Contact:

Post by Sof_T » Tue Jul 07, 2009 12:46 pm

sds wrote:And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...
The empty template just creates a project with the correct library paths, etc for using the wxWidgets libraries. You have to add all the code. So that is quite normal.
The home of Sof.T http://www.sof-t.site88.net/
Author of Programming with wxDevC++
http://sourceforge.net/projects/wxdevcpp-book/

sds
Earned a small fee
Earned a small fee
Posts: 17
Joined: Tue Jul 07, 2009 12:08 am

Post by sds » Tue Jul 07, 2009 1:50 pm

Sof_T wrote:
sds wrote:And what about the empty template project? Is that normal? I expected something like "Hello world" with a button to press...
The empty template just creates a project with the correct library paths, etc for using the wxWidgets libraries. You have to add all the code. So that is quite normal.
Thanks, then everythink seems to be working now. The Allegro Pack was running right from the start.
Stefan Schmollack http://schmollack.net/

Post Reply