wxDevCpp crashes under Win9x

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
Post Reply
PierreC
In need of some credit
In need of some credit
Posts: 2
Joined: Thu Apr 03, 2008 8:45 am

wxDevCpp crashes under Win9x

Post by PierreC » Thu Apr 03, 2008 9:04 am

Hi,
I need some help :
I've tried to install wxDevCpp (6.10.2, 610.1, 6.10beta...) on an old PC running win98. The installation process worked fine, BUT i can't launch wxDevCpp : i only get "Runtime error 216 at xxxx".
I'm quite sure there is no viruses on this PC, the disks have been reformated yesterday, and i've checked the system with some antivirus application... and wxDevCpp is the only application that have this behaviour...

could anyone helpme ???
Pierre

protocol
Moderator
Moderator
Posts: 680
Joined: Wed Jan 18, 2006 6:13 pm
Location: Dallas, TX
Contact:

Post by protocol » Sun Apr 06, 2008 12:39 am

Wow, I thought they banned win9x.

Try installing the Delphi 6 runtimes, as wxDevCpp is written in Pascal.

I don't know which ones for sure, but the latest should do the trick.

Best regards.
/* UIKit && wxWidgets 2.8 && Cocoa && .Net */
QuRegExmm
wxPCRE & ObjPCRE - Regex It!

PierreC
In need of some credit
In need of some credit
Posts: 2
Joined: Thu Apr 03, 2008 8:45 am

Post by PierreC » Mon Apr 07, 2008 7:31 am

thanks for the info...
but where could i find these runtimes ??
I'm not a registred user of Delphi...

I hadn't this problem when installing wxDevCpp under winXP, even without the delphi runtimes...

Pierre
Pierre

protocol
Moderator
Moderator
Posts: 680
Joined: Wed Jan 18, 2006 6:13 pm
Location: Dallas, TX
Contact:

Post by protocol » Tue Apr 22, 2008 3:03 am

Google: "Delphi 6" runtime

best regards.
/* UIKit && wxWidgets 2.8 && Cocoa && .Net */
QuRegExmm
wxPCRE & ObjPCRE - Regex It!

ghost
In need of some credit
In need of some credit
Posts: 1
Joined: Thu Jul 31, 2008 7:42 pm

Post by ghost » Thu Jul 31, 2008 7:49 pm

I´d like to use wxdev on my system ( win98 SE :oops: ) too. 6.10.1 runs without a problem. But if i try the newest version there comes a runtime error 216.

After i read this thread i installed the Delphi runtimes from this site ( http://www.net-tools.org/download.htm ). But this dont work.

Is this the right runtime? What can i do?

Edit, the following come after the start stop:
DEVCPP verursachte einen Fehler durch eine ungültige Seite
in Modul <Unbekannt> bei 0000:00000000.
Register:
EAX=00000000 CS=0000 EIP=00000000 EFLGS=00000000
EBX=00000000 SS=0000 ESP=00000000 EBP=00000000
ECX=00000000 DS=0000 ESI=00000000 FS=0000
EDX=00000000 ES=0000 EDI=00000000 GS=0000
Bytes bei CS:EIP:

Stapelwerte:
After closing this window, the runtime error appears...

Post Reply