Page 1 of 4

wxDev-C++ 6.10.2 released

Posted: Thu Mar 22, 2007 6:08 am
by tbreina ... _id=495439

We've released 6.10.2, which is a bugfix release. wxWidgets libraries have been upgraded to the latest 2.8.2.

I'm hoping that Joel will be able to post the executable and new wxWidgets devpaks to our devpak server soon. This way current users can just use the WebUpdate method to upgrade. In the meantime, you're free to use the full installer at the link above.

*Fixed several memory leaks from Dev-C++
*Splitter window code generation bug (1632878)
*Private resources not generated at project load (1622858)
*Output directories created too eagerly (1611923)
*Made object directory �Objects�
*Multiple sizer alignment flags now allowed
*Empty project -> no .dev file created bug (1611895)

NOTE: SVN HEAD has some additional bug fixes and some major new feature enhancements. I tried to pull out just the bug fixes and apply them to 6.10.1 to get 6.10.2.


Posted: Fri Mar 23, 2007 3:54 pm
by LosHuliganos
Why that is not accessible throw the download in main web page? :shock:

Posted: Mon Mar 26, 2007 7:16 am
by lowjoel
Sorry I was kinda busy over the last week or so hence I've only updated it yesterday.

I'll get the changes onto WebUpdate once I get the necessary files.


Posted: Mon Mar 26, 2007 11:33 am
by tommyd
hmm I'm unable to add WxSave/OpenFileDialogs anymore.
It declares them in the h file but doesn't initialize them in the CreateGuiControls method ?
Am I missing something?!

I added severals of them but no one gets initialized
My program crashes due to this and is on halt, will have to install 6.10.1 for the time being :/

but other than that, great job, it really feels more bug free :P

e: I just tried on a friends pc also with the latest version and a new project, and he has no problems adding those dialogs :/
What differs from my project is that mine's more mature :/

Posted: Mon Mar 26, 2007 1:07 pm
by clauchau
I eagerly downloaded it on sourceForge but my antivirus says wxdevcpp_6.10.2_setup.exe has got VirusBurst and it prevents me to use it. It's the first time such a thing has ever happened to me.

Is it a false alert and can the file be trusted anyway?

Posted: Mon Mar 26, 2007 1:15 pm
by lowjoel
I have a strong feeling that your antivirus is raising a false alarm. I think this is due to the NSIS installer we use. There are many programs which use the NSIS installer and some antivirus programs report these files as "viruses". See

To the best of our knowledge the file does not contain viruses and has not be tampered with since release.


Posted: Mon Mar 26, 2007 1:22 pm
by clauchau
Thanks for your answer. I'll try to bypass my (Symantec) antivirus then and report how it went.

Posted: Mon Mar 26, 2007 1:27 pm
by lowjoel
That's interesting. Maybe you are using the Corporate version but my Norton works very well. If I am not wrong they use the same core engine to scan files, but I'm not too sure.

Do keep me posted.


Posted: Mon Mar 26, 2007 2:52 pm
by clauchau
Ok, Version 10.6.2 is now running fine :D - I ran the installer and then launched the IDE.

And my computer is not infected :) - I then ran a partial antivirus check that checked the memory and the main files and entry points of my hard disk, it went fine, and I also looked for the specific registry keys and files that would show up if VirusBurst was there, and there wasn't any such trace of infection.

The culprit seems to be Symantec Antivirus then. I have the Corporate edition version with the latest virus definition (25/03/2007).

So, we can keep trusting sourceForge as always.

Posted: Mon Mar 26, 2007 5:15 pm
by tbreina
clauchau wrote: The culprit seems to be Symantec Antivirus then. I have the Corporate edition version with the latest virus definition (25/03/2007).

So, we can keep trusting sourceForge as always.
Yes, as Joel mentioned, I think this is a false positive due to the NSIS installer we use. For some reason, some anti-virus manufacturers flag NSIS code falsely. I thought NSIS had resolved the problem a few versions ago.

Please do let me know if anything suspicious pops up. I created the install package and definitely want to know if there's a problem.


Re: wxDev-C++ 6.10.2 released

Posted: Tue Mar 27, 2007 12:17 am
by LosHuliganos
I have a problem. I made project for gcc and tried to compile it with studio 2005. It keeps saying me CVTRES : fatal error CVT1100: duplicate resource. type:MANIFEST, name:1, language:0x0409 . As I understood in studio a manifest files can be turned off. But in wxDevCpp I did't find a way around.

Posted: Tue Mar 27, 2007 10:11 am
by lowjoel
Project > Project Options > Uncheck the Enable XP Themes checkbox.

Posted: Tue Mar 27, 2007 6:49 pm
by LosHuliganos
lowjoel wrote:Project > Project Options > Uncheck the Enable XP Themes checkbox.
Somehow it works... :shock: What it was? May be some bug fix should be done!?

Posted: Tue Mar 27, 2007 9:47 pm
by lowjoel
Visual C++ adds in a manifest on it's own, so the .Res files have 2 manifest resources. Until I rewrite the compiler object you'll have to use this work-around.


Shouldn't we optimize the code implement funtion?

Posted: Sat Mar 31, 2007 8:26 am
by kin.ming
Hi, LowJoel.

Well, I am so happy when I found out there is an excellent and free wx-IDE . Thanks to Joel. But after a time of testing , I found out that the code implement is far from satisfation. As mentioned follow:

1. The parameters of funtions. I suppose the hints should have came out when "(" token.
2.For STL support, you minht have your code understand the templates .

Joel, I'm a delphi programmer myself. I checked your code , the cache-generating part has to be improved. What I don't understand is that why you use MadException . They doesn't have free version any more when I wanted to download one a few days ago.

Forgive my poor English, I'm a new college student from China.

I'm greatfull of your work, really!