Need some help with wxDev-C++  [SOLVED]

If you are using wxDev-C++ for your wxWidgets design, please ask your questions here instead of in IDE Related.
art-ganseforth
Experienced Solver
Experienced Solver
Posts: 71
Joined: Mon Sep 01, 2014 10:14 am

Need some help with wxDev-C++

Postby art-ganseforth » Fri Sep 07, 2018 3:03 pm

Hi there,

okay, this might be a littlebit strange, but i'm a hobby-programmer using C++, but i never lerned how to use a makefile. I alsways used tools or predefined installeble packages. This is also the reason, why i use the old devc-ide. Once i downloaded a package, where all librarys that i currently need were included. With this installation i worked for a log time now, without doing any changes. Once i tried to compile my project with CodeBlocks, but witout success.

Unfortunatly some days ago something with my OS went wrong temporarily, which caused me to try to reinstall the wxWidgets-DevPack. Now it doesn't work anymore.

It seems (after reading some forum-posts) that i somehow installed another version of wxWidgets, so that somehow the headers do not match the librarys but i'm not sure. Currently the compiler (MinGW) / linker reports some

Code: Select all

[Warning] duplicate section `.rdata$_ZTV20wxMDIParentFrameBase[vtable for wxMDIParentFrameBase]' has different size
and a lot of

Code: Select all

[Linker Error] undefined reference to `wxWindowBase::IsDescendant(wxWindowBase*) const'
messages.

I already tried to change some path-settings, but without success but i do not dare to change too much. So it would be good if someone coud help me.


Best,
Frank

art-ganseforth
Experienced Solver
Experienced Solver
Posts: 71
Joined: Mon Sep 01, 2014 10:14 am

Re: Need some help with wxDev-C++  [SOLVED]

Postby art-ganseforth » Sat Sep 08, 2018 10:00 am

Got it...


Return to “wxDev-C++”

Who is online

Users browsing this forum: No registered users and 3 guests