wxDialog

This forum can be used to talk about general design strategies, new ideas and questions in general related to wxWidgets. If you feel your questions doesn't fit anywhere, put it here.
Post Reply
theWolf
Knows some wx things
Knows some wx things
Posts: 43
Joined: Wed May 18, 2005 12:27 am

wxDialog

Post by theWolf » Thu Dec 08, 2005 10:36 pm

Hello,
I created a wxDialog and the exit X box in the upper right corner stays gray. How can I activate it?

Thank you.
______________
WxWidgets 2.6.1, .net 2003, Windows2000
Sometimes there's a lot of gravel around the gems. WxWidgets is a gem!

lowjoel
Moderator
Moderator
Posts: 1511
Joined: Sun Jun 19, 2005 11:37 am
Location: Singapore
Contact:

Post by lowjoel » Fri Dec 09, 2005 1:06 am

in the ctor, pass wxCLOSE_BOX (or the like) in styles.

theWolf
Knows some wx things
Knows some wx things
Posts: 43
Joined: Wed May 18, 2005 12:27 am

wxDialog

Post by theWolf » Fri Dec 09, 2005 1:48 am

Thank you for the suggestion.
I had used wxDEFAULT_DIALOG_STYLE which included wxCLOSE_BOX

Anyway, I changed it to the following:
wxDEFAULT_DIALOG_STYLE|wxCLOSE_BOX

No change.
the "X" box is still grayed.
______________
WxWidgets 2.6.1, .net 2003, Windows2000
Sometimes there's a lot of gravel around the gems. WxWidgets is a gem!

theWolf
Knows some wx things
Knows some wx things
Posts: 43
Joined: Wed May 18, 2005 12:27 am

wxDialog

Post by theWolf » Fri Dec 09, 2005 2:52 am

OK, this is strange.
When I was having the trouble with the "X" box grayed I was using an old Dell Laptop (Windows98se).

Wife came home, so I sent my project to my office computer and drove to the office. At the office I use Windows2000pro. I works fine.

The "X" box is grayed using Windows98se.
The "X" box is active when run on Windows2000pro.

Strange. :?

Dev-cpp 4.9.9.2, WXWidgets 2.6.1 packet
______________
WxWidgets 2.6.1, .net 2003, Windows2000
Sometimes there's a lot of gravel around the gems. WxWidgets is a gem!

Jorg
Moderator
Moderator
Posts: 3971
Joined: Fri Aug 27, 2004 9:38 pm
Location: Delft, Netherlands
Contact:

Post by Jorg » Fri Dec 09, 2005 7:02 am

Sounds like a clash of flags. Maybe you should (if you have the time) check if the flags translated to Win98 API are the same as the flags for the Win2000 API.

Especially the close blox flag, maybe something changed in the API for WinNT (2K and XP)

Regards,
- Jorgen
Forensic Software Engineer
Netherlands Forensic Insitute
http://english.forensischinstituut.nl/
-------------------------------------
Jorg's WasteBucket
http://www.xs4all.nl/~jorgb/wb

theWolf
Knows some wx things
Knows some wx things
Posts: 43
Joined: Wed May 18, 2005 12:27 am

wxDialog - It works now!

Post by theWolf » Sun Dec 11, 2005 10:57 pm

When I returned home the "X" box was showing up on the wxdialog running on the Windows98se laptop???

It must be a problem with the old Windows98se or the laptop.

I guess when it comes to Windows it always a good idea to
REBOOT! first.

Sorry for the trouble.
______________
WxWidgets 2.6.1, .net 2003, Windows2000
Sometimes there's a lot of gravel around the gems. WxWidgets is a gem!

Post Reply