Page 1 of 1

licence de wxWidgets et ses obligations

Posted: Mon Sep 14, 2020 7:55 am
by kikilabe
Hello my name is kiba and I am new to wxWidgets or wxWidgets.

I would like to know something about wxWidgets license and its obligations.

I am also new to programming.

If for example I created an application and my license is private is it compulsory to pay to have the license.

If for example I created an application and my license is commercial, is it compulsory to pay to have the commercial license.

I can know how to choose the type of license in an application for example I use << wxAboutDialogInfo >> and if I say << Getlicence >> it displays << Setlicence >> it is necessary to enter a text, I can get it Is it like that or did I do it wrong

Info: the version of wxWidgets 3.0 or 3.1.4 others appeared difficult so I started with version 2.8.12



c++ avec wxWidgets :D :D :D
Bonjours je m'appelle kiba et je suis nouveau en wxWidgets ou wxWidgets.

je voudrais savoir des chose a propos de licence de wxWidgets et ses obligations.

je suis également débutant dans le programmation :oops: :oops: :oops:

:oops: :oops:

Si par exemple je créé un application et que mon licence est privée est-il obligatoire de payes pour avoir la licence .

Si par exemple je créé un application et que mon licence est commercial est-il obligatoire de payes pour avoir la licence commercial .

Je peux savoir comment choisir le type de licence dans une application par exemple moi j'utiliser << wxAboutDialogInfo >> et si je dis << Getlicence >> ça afficher << Setlicence >> il faut entre un texte, je pige est-ce que cest comme ça ou est-ce que j'ai mal fait

Info : la version de wxWidgets 3.0 ou 3.1.4 autres mon apparu difficile donc j'ai commence par la version 2.8.12

Merci D'avance

Re: licence de wxWidgets et ses obligations

Posted: Mon Sep 14, 2020 9:03 am
by PB
AFAIK, wxWidgets uses its own licence, which is basically modified LGPL.

In other words, you do not have to pay, regardless if your application is free or commercial. You also do not have to publish the source of your application. See http://wxwidgets.org/docs/faq/general/#licence

I strongly recommend to start with a supported version of wxWidgets, i.e., the version 3 one. Version 2.8 is obsolete and unsupported. What did you find difficult about using the supported version?

Re: licence de wxWidgets et ses obligations

Posted: Mon Sep 14, 2020 9:04 am
by catalin
Hi Kiba,

[You probably won't find many users around here that will answer you in French]

You are allowed to create your closed source app with private license, or commercial license, or any other kind, and there is nothing to pay for using wxWidgets.

You don't set a type of license in wxAboutDialogInfo. You just set the text of the license, and you define its purpose, permissions, restrictions there. There's nothing more to it (unless I've missed your point here).

Info: as a beginner, at least with wxWidgets, you should start with the highest version available. Today, that would be 3.1.4. Also, there is absolutely no reason for you to back as far as 2.8.12, and personally I strongly advice against that.

Re: licence de wxWidgets et ses obligations

Posted: Mon Sep 14, 2020 11:58 am
by kikilabe
honnêtement j'ai essayé une fois de faire un application avec la version 3.1.4 et ça na pas marche puis j'ai pas trouve des Didacticiel pour la version 3.1.4 et même pour les autres sauf la version 2.8.12 donc je me suis dit d'apprendre la version 2.8
après tu pourrais aller vers haut 3.0 3.1

Merci d'avance

translated message

honestly I tried once to make an application with version 3.1.4 and it didn't work then I couldn't find Tutorials for version 3.1.4 and even for others except version 2.8.12 so I am told to learn version 2.8
then you could go up 3.0 3.1

thank you in advance

Re: licence de wxWidgets et ses obligations

Posted: Mon Sep 14, 2020 8:51 pm
by ONEEYEMAN
Hi,
What problems issues did you face with the version 3.1.4?
Please try again and post here with any problems you will have so we can help you resolve them.

Also, it would be nice to know what platform/compiler you will be using, so that we can direct you accordingly and helpyou resolve all issues with the 3.1.4.

Thank you.

P.S.: There is one person who speaks French on this forum. You will have much better chance of getting helpif you just post in English and omit the French portion all-together.

Re: licence de wxWidgets et ses obligations

Posted: Tue Sep 15, 2020 7:34 pm
by kikilabe
thank you for your reply

Honest, I haven't tried version 3.1.4 too much because I haven't found a tutorial that explains me. except I found tutorials for version 2.8.12, then I told myself that version 2.8.12 is simpler than version 3.1.4 and even for 3.0. you advise me to leave version 2.8.12 and change to 3.1.4

info: message translate by Google translate. C ++ Windows 8.1 vc ++ 12 :D :D

thank you in advance

Re: licence de wxWidgets et ses obligations

Posted: Tue Sep 15, 2020 8:16 pm
by ONEEYEMAN
Hi,
The issue is that with every release you will get a bunch of bug fixes and new features.
Also keep in mind that version 2.8.12 is really, really outdated - it is released approximately 10 years ago or even further away.
Remember - if something doesn't work in 2.8.12 - chances are it is fixed in the latest release.
There are huge number of fixes in the latest version and a lot of new features.

On top of that it is easier to work with the latest release (3.1.4) than with 2.8 series.

Open the appropriate solution from wxWidgets\build\msw (wx_vcN.sln).
Compile it as Debug, Static).
Create a new project in MSVC.
Close the project
Copy wxwidgets.props file to the directory of the new project.
Open the project back up.
Start writing the code.

I don't think it requires any tutorial. ;-)

If you get stuck with something - check the appropriate sample first.
If it still doesn't work - ask here on the forum.

So, all in all, get the version 3.1.4 and give it a spin.
Remember - we are all here to help, especially newcomers.

Thank you.

Re: licence de wxWidgets et ses obligations

Posted: Thu Sep 17, 2020 7:42 pm
by kikilabe
thank you for your reply. I was unable to compile version 3.1.4. but I received on version 3.5

Re: licence de wxWidgets et ses obligations

Posted: Thu Sep 17, 2020 7:53 pm
by ONEEYEMAN
Hi,
Did you get any error(s) compiling the library itself or your code?
If yes -could you please post them.

And there is no version 3.5. You probably meant 3.1.5 wich is the latest master, right?

Thank you.

Re: licence de wxWidgets et ses obligations

Posted: Tue Sep 22, 2020 8:25 pm
by kikilabe
Hello yes i encountered errors while compiling libraries, it told me i couldn't find wx .. 3.1.4 lib even though it had just started compiling i fixed the problem by setting wxavd first and compilation was successful, when we open the solution there are 24 wxhtml, wxnet, .... folders, the first one is cusmbo I think, so I just cancel the compilation of wxcusmbo and so I have 23 folders in the folder created by vc ++ / buil / msw / vsmud / la,

I tested the libraries and it works without problem. I'm sorry I forgot the name of wx ... 3.1.4 no I don't think it's 3.1.5 but I'd rather say it's 3.0.5

In version 3.1.4, is it possible to create Android applications?

I am really really sorry to answer you so late I have an internal connection problem so I am not always connected

I sincerely thank you

Re: licence de wxWidgets et ses obligations

Posted: Tue Sep 22, 2020 9:04 pm
by ONEEYEMAN
Hi,
That's OK - for being late.

No Android is unfortunately not supported.
You can try an experimental Android branch from the GSOC couple of years ago, but it is not inside the mainline of the library.

If you want to try it - Google the wxWidgets Android and hopefully you will get the info on how to build the library and the application.

Also, it would be nice if you can try to grab the latest sources and try to build them again in your environment.
And if you hit any errors - post them here.

That way we will know what the problem is and will be able to solve it for everybody benefits.

Thank you.