Page 2 of 2

Re: Why there is no compiled WxWidgets version?

Posted: Thu Dec 21, 2017 3:38 pm
by xaviou
gtafan wrote:Yes I prefer to get the sorces, or to be more precise headers, from the official site and avoid git.
git is not mandatory : I also provide a sources archive.
gtafan wrote:Is there some kind of reedmee about how to bring the sorces and this compiled libs together, so it´ll worck in Code Blocks?
I wrote a small article on how to install these libs : https://wxstuff.xaviou.fr/article/built ... stall.html
Just follow it and don't hesitate to ask if it needs more precise informations.

Regards
Xav'

Re: Why there is no compiled WxWidgets version?

Posted: Fri Dec 22, 2017 11:37 am
by gtafan
xaviou wrote:
gtafan wrote:Yes I prefer to get the sorces, or to be more precise headers, from the official site and avoid git.
git is not mandatory : I also provide a sources archive.
gtafan wrote:Is there some kind of reedmee about how to bring the sorces and this compiled libs together, so it´ll worck in Code Blocks?
I wrote a small article on how to install these libs : https://wxstuff.xaviou.fr/article/built ... stall.html
Just follow it and don't hesitate to ask if it needs more precise informations.

Regards
Xav'
Thanks.

Re: Why there is no compiled WxWidgets version?

Posted: Mon Aug 20, 2018 11:49 am
by gtafan
xaviou wrote:Hi.
eranon wrote:There are compiled wxWidgets available on the wxWidgets website (see the "Binaries" section): https://www.wxwidgets.org/downloads/
And if the choice you have using this link, you can have a look here : you will be able to download differents configurations that can be installed in one time.

Regards
Xav'
Posibly i am just to stupied, but i have extracted the content of the lib folder of "wxWidgets-3.0.4-gcc510TDM-x64-32bits-Static-Monolibs.7z" to the lib folder of "wxWidgets-3.0.4". However when I try to start a wxwidgets project in CodeBlocks I am geting an error mesage:

Image

What have I done wrong?

Re: Why there is no compiled WxWidgets version?

Posted: Mon Aug 20, 2018 12:35 pm
by xaviou
Hi
gtafan wrote: Posibly i am just to stupied, but i have extracted the content of the lib folder of "wxWidgets-3.0.4-gcc510TDM-x64-32bits-Static-Monolibs.7z" to the lib folder of "wxWidgets-3.0.4". However when I try to start a wxwidgets project in CodeBlocks I am geting an error mesage:

Image

What have I done wrong?
I agree it's not very clear in the installation article.
If you want to use the downloaded libs "as is", you must specify the "Configuration" field of C::B project wizard.
Image
It must contain "32" or "64" for 32 or 64 bits multi-libs and "32_Mono" or "64_Mono" for monolithics libs.

If you want to get rid of that, just rename the lib folder after extraction (it must be something like "WX_INSTALL_DIR\lib\gcc_lib\" or "WX_INSTALL_DIR\lib\gcc_dll").

Hope it'll help. : if not, don't hesitate to re-ask...

Regards
Xav'

Re: Why there is no compiled WxWidgets version?

Posted: Tue Aug 21, 2018 11:23 am
by gtafan
xaviou wrote:Hi
gtafan wrote: Posibly i am just to stupied, but i have extracted the content of the lib folder of "wxWidgets-3.0.4-gcc510TDM-x64-32bits-Static-Monolibs.7z" to the lib folder of "wxWidgets-3.0.4". However when I try to start a wxwidgets project in CodeBlocks I am geting an error mesage:

Image

What have I done wrong?
I agree it's not very clear in the installation article.
If you want to use the downloaded libs "as is", you must specify the "Configuration" field of C::B project wizard.
Image
It must contain "32" or "64" for 32 or 64 bits multi-libs and "32_Mono" or "64_Mono" for monolithics libs.

If you want to get rid of that, just rename the lib folder after extraction (it must be something like "WX_INSTALL_DIR\lib\gcc_lib\" or "WX_INSTALL_DIR\lib\gcc_dll").

Hope it'll help. : if not, don't hesitate to re-ask...

Regards
Xav'
Thanks for the answer, at the end I had to build everithing myself, which took me at least an hour again. I had already tried to rename it to "WX_INSTALL_DIR\lib\gcc_lib\", but didn´t help. Posibly the gcc version wasn´t exactly the same, have to check that.

Re: Why there is no compiled WxWidgets version?

Posted: Wed Oct 16, 2019 9:17 am
by gtafan
Very strange the GCC-4.9.2-TDM is not there.

Image

Re: Why there is no compiled WxWidgets version?

Posted: Wed Oct 16, 2019 5:31 pm
by xaviou
Hi.
gtafan wrote:
Wed Oct 16, 2019 9:17 am
Very strange the GCC-4.9.2-TDM is not there.

Image
The problem is that all "wx-3.0.4" links are related to the same page witch was updated each time.
And the last time it has been updated, I didn't made the Gcc-4.9.2-TDM Version.

So the really correct post is the last one (in date value) witch is related to this version.

Do you really need this ?

Regards
Xav'

Re: Why there is no compiled WxWidgets version?

Posted: Fri Oct 18, 2019 10:32 am
by gtafan
xaviou wrote:
Wed Oct 16, 2019 5:31 pm
Hi.
gtafan wrote:
Wed Oct 16, 2019 9:17 am
Very strange the GCC-4.9.2-TDM is not there.

Image
The problem is that all "wx-3.0.4" links are related to the same page witch was updated each time.
And the last time it has been updated, I didn't made the Gcc-4.9.2-TDM Version.

So the really correct post is the last one (in date value) witch is related to this version.

Do you really need this ?

Regards
Xav'
Unforunately yes, my CodeBlocks version uses this compiler at the moment. Also see no reason, why there should be no GCC-4.9.2-TDM version since ther is GCC-4.8.1-TDM one.