System Requirement

This forum can be used to talk about general design strategies, new ideas and questions in general related to wxWidgets. If you feel your questions doesn't fit anywhere, put it here.
Post Reply
DeeJayOne
In need of some credit
In need of some credit
Posts: 1
Joined: Sun Mar 31, 2024 5:03 pm

System Requirement

Post by DeeJayOne »

Hi Everyone :D

Is there an official document with the system requirement ? (for each version)

I can see on the following webpage that Windows XP is still compatible : https://wxwidgets.org/about/
"wxMSW: The port for 32-bit and 64-bit Windows variants including Windows XP, Vista, 7, 8, 10 and 11."

But on the github webpage https://github.com/wxWidgets/wxWidgets, it seems Windows XP will be lost.
"Windows 7, 8, 10 and 11 (32/64 bits)."
"Please use 3.2 branch if you must use wxWidgets with a C++98 compiler or support Windows XP."

Does it mean Windows XP won't be compatible from 3.3 releases ?
PB
Part Of The Furniture
Part Of The Furniture
Posts: 4204
Joined: Sun Jan 03, 2010 5:45 pm

Re: System Requirement

Post by PB »

DeeJayOne wrote: Sun Mar 31, 2024 5:17 pm Does it mean Windows XP won't be compatible from 3.3 releases ?
Yes, the support is no longer there.

I think it is stated pretty clearly in the text you quoted.
Post Reply