wxlua build on MacOS 10.15

This forum can be used to talk about general design strategies, new ideas and questions in general related to wxWidgets. If you feel your questions doesn't fit anywhere, put it here.
Post Reply
ianq
In need of some credit
In need of some credit
Posts: 2
Joined: Mon Apr 05, 2021 2:22 pm

wxlua build on MacOS 10.15

Post by ianq » Mon Apr 05, 2021 6:19 pm

Am attempting to build wxlua so that I can use wxWidgets in a scripting language, of which I have decent experience with lua.

I have followed the instructions for building on the wxlua GitHub page to the letter, wxWidgets builds and tests fine, but when I go to build wxlua, it fails when it is linking to the wxWidgets build.

I spoke to Paul over at the wxlua GitHub page, he thinks the error I am getting may have to do with how I configured wxWidgets. I have tried countless configs of both wxWidgets and wxlua to no avail, keep getting this error:

[ 90%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxlcallb.cpp.o
[ 90%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxlconsole.cpp.o
[ 91%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxllua.cpp.o
[ 91%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxlobject.cpp.o
[ 92%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxlstate.cpp.o
[ 93%] Building CXX object modules/luamodule/CMakeFiles/wxLuaModule.dir/__/wxlua/wxlua_bind.cpp.o
[ 93%] Linking CXX shared library ../../lib/Debug/libwx.dylib
ld: framework not found -lAVKit
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/Debug/libwx.dylib] Error 1
make[1]: *** [modules/luamodule/CMakeFiles/wxLuaModule.dir/all] Error 2
make: *** [all] Error 2

Has anybody on here managed to build wxlua on MacOS 10.15.7, using wxWidgets 3.1.4 and wxlua 3.1.0.0?

I am not very conversant with make and cmake tools, have hacked around cmake as much as I could, but still no joy.

The latest configure I used for wxWidgets is:

Code: Select all

#!/bin/bash

# Mac OS X global settings
MACOSX_ARCH="x86_64"
MACOSX_VERSION="10.15"
MACOSX_SDK_PATH="/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX11.1.sdk"

../configure --prefix=$PWD \
                 --with-osx-cocoa \
                 --enable-unicode \
                 --disable-shared \
                 --enable-macosx_arch=$MACOSX_ARCH \
                 --with-macosx-version-min=$MACOSX_VERSION \
                 --with-macosx-sdk=$MACOSX_SDK_PATH \
                 \
                 --enable-debug 2>&1 | tee configure-basic.log
Any thoughts, help, curses appreciated, I am just about to give up on wxlua and ever getting it built.

Thx...IanQ

User avatar
doublemax
Moderator
Moderator
Posts: 15827
Joined: Fri Apr 21, 2006 8:03 pm
Location: $FCE2

Re: wxlua build on MacOS 10.15

Post by doublemax » Mon Apr 05, 2021 7:38 pm

I don't know anything about wxLua or wxWidgets under OSX, but i would first focus on the actual error message:

Code: Select all

ld: framework not found -lAVKit
Do you link to AVKit when building wxLua? If not, try adding it. If yes, try to find out why it's not found.
Use the source, Luke!

ianq
In need of some credit
In need of some credit
Posts: 2
Joined: Mon Apr 05, 2021 2:22 pm

Re: wxlua build on MacOS 10.15

Post by ianq » Mon Apr 05, 2021 9:43 pm

According to Paul from wxlua, wxlua doesn't link to AVKit, it may do with the media component of wxWidgets, my uneducated guess was when wx-config gets called from the wxlua build...

I am a complete neophyte with builds/linking/etc so please bear with my ignorance, I have learned much in the past few weeks, but obviously not enough yet.

IanQ

Post Reply