Page 1 of 1

no native gui

Posted: Fri Dec 23, 2005 9:16 pm
by caminoix
hello :)

i have a problem with i don't have my native gui in it should be baghira (tried also on plastik and keramik) but it looks like cde or something of the sort.
i've tried running samples from a freshly downloaded compiled version and it looks the same :(
i'm using linnexos 0.85 (based on pclinuxos based on mandriva).
what could be the reason?

Posted: Fri Dec 23, 2005 9:27 pm
by leio
The reason could be use that what you are seeing is your GTK+ theme, but the you are expecting it to magically get a KDE theme. You need to set up your systems GTK+ to use a similar theme, or the gtk-qt theme engine.
Also, I hope your wxGTK is linked against GTK2 (default since wx2.6), not GTK1. If I hear "looks like CDE" I think GTK1. However, if your default GTK2 theme is the built-in one, it might very well be that too.

Posted: Fri Dec 23, 2005 10:30 pm
by caminoix
hmm, yup... this reminded me why i turned gtk-qt engine off some time ago: because when i turn it on, gimp doesn't work reporting a segmentation fault. so i have to chose between native wxnet or gimp...
perhaps you know what could be the solution to that?
well, anyway, what you've said answered my question, even if it had been posed badly :) ait

Posted: Fri Dec 23, 2005 11:57 pm
by leio
I believe an older gtk-qt engine did awful things with its custom backing pixmap (related to double-buffering and such) - not setting the colormap, or it being different or something from that line.
Newest GTK+ versions started to slap stuff that did that, so it might (and I vaguely recall it being so) be fixed now in a latest gtk-qt engine.