[WINCE] - menu sample not working on wince

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
schmallaria
Earned a small fee
Earned a small fee
Posts: 24
Joined: Fri Aug 19, 2005 9:54 am

[WINCE] - menu sample not working on wince

Post by schmallaria » Mon Feb 27, 2006 3:03 pm

hello,

after getting my brand new windows mobile 5.0 device i want to do some experiments with wxwidgets and this device.

but when i compile the wxwidgets menu sample it don't work on the device. there is no menubar, i can only see the button for the display keyboard. when i start the same executable on my older windows mobile 2003 se device it runs successfully.

can anyone help me?

i'm using evc++ 4.0, ppc 2003 sdk, wxwidgets 2.6.2 and 2.6.3rc1

thanks a lot
schmallaria

User avatar
ABX
Can't get richer than this
Can't get richer than this
Posts: 810
Joined: Mon Sep 06, 2004 1:43 pm
Location: Poznan, Poland
Contact:

Re: [WINCE] - menu sample not working on wince

Post by ABX » Mon Feb 27, 2006 4:03 pm

schmallaria wrote:but when i compile the wxwidgets menu sample it don't work on the device.
Menu sample is not most trivial sample. If it makes problems it is worth to check minimal sample.
schmallaria wrote:there is no menubar, i can only see the button for the display keyboard. when i start the same executable on my older windows mobile 2003 se device it runs successfully.
It seems that exactly the same problem is currently investigated at:
http://lists.wxwidgets.org/cgi-bin/ezml ... :sss:71014
There are some suggestions how to debug it so if you could find solution, that would be great. If you want to join discussion, you can post to wx-dev mailing list using gmane interface: http://thread.gmane.org/gmane.comp.lib. ... evel/70580

ABX
CVS Head, 2.8.X
wxMSW, wxWinCE, wxPalmOS, wxOS2, wxMGL, bakefile
gcc 3.2.3, bcc 5.51, dmc 8.48, ow 1.6, vc 7.1, evc 3/4, pods 1.2

Post Reply