Page 1 of 1

Mageia 7.1 and GTK

Posted: Sat Feb 08, 2020 11:13 am
by raananb
I have no experience in rpm-based Linux, but would like to set up Mageia 7.1 with GTK in order to investigate a bug in my application which comes up in Debian-based Linux distributions (Ubuntu & Mint), apparently in the base unix software. The bug is not produced in Windows or OSX versions of the application.

configure for wxWidgets build in Mageia (with with toolkit wxGTK+2) fails with

'GTK+ is incorrectly installed. ... For GTK+2 please ensure that pkg-config is in the path and that gtk+-2.0.pc is installed.'

Mageia Software management application does not find gtk+-2.0.pc neither in Installed nor in Not installed categories.

I have no idea how to find and install gtk+-2.0.pc and its dependencies in this envoronment.

Some help would be welcome.

Re: Mageia 7.1 and GTK

Posted: Sat Feb 08, 2020 12:00 pm
by DavidHart

Debian-derived distros tend to call their packages libfoo-dev; rpm-ish ones are more likely to call them foo-devel or libfoo-devel. Mageia goes one step further (downhill) and often calls them lib64foo-devel.

Your missing package is lib64gtk+2.0-devel.



Re: Mageia 7.1 and GTK

Posted: Sat Feb 08, 2020 12:11 pm
by raananb
Thanks, that worked as expected.

I also need a webkit for wxWebView, but configure does not find webkit-1.0 and neither do I. Again, the software center is not helpful.

Mageia forum indicated the following:


and added that they have worked hard to get rid of webkit1.0

I installed all three above.

../configure --with-gtk=2 was not satified and disabled webview.

How can configure be configured to look for other webkits?

Still stuck.

Re: Mageia 7.1 and GTK

Posted: Mon Feb 10, 2020 4:14 pm
As pointed out by Vadim on the ML you should use "--with-gtk=3".

GTK+2 is seriously outdated and is no longer supported by GTK/GNOME devs. All effort is coming into GTK+4 and GTK+3 only receives bug fixes.

Thank you.

P.S.: If you software is build and released with GTK+2 and the bug manifests itself with GTK+2 - try with GTK+3.