Page 1 of 1

Ubuntu 19.10 & webkit

Posted: Fri Jan 24, 2020 9:13 pm
by raananb
'configure' tests for the present of webkit-1.0, as shown in the lines from confogure.log below

No package 'webkit-1.0' found
configure:36557: WARNING: webkitgtk not found.
configure:36594: WARNING: WebKit not available, disabling wxWebView

However, Ubuntu 19.10 does not have a webkit-1.0 and does not allow to install it, while the following kits are installed:

libwebkit2-sharp-4.0-cil-dev/eoan 2.10.9+git20160917-1.1 amd64
libwebkit2-sharp-4.0-cil-dev/eoan 2.10.9+git20160917-1.1 i386
libwebkit2-sharp-4.0-cil/eoan 2.10.9+git20160917-1.1 amd64
libwebkit2-sharp-4.0-cil/eoan 2.10.9+git20160917-1.1 i386
libwebkit2gtk-4.0-37-gtk2/eoan-updates,eoan-updates,eoan-security,eoan-security,now 2.26.2-0ubuntu0.19.10.1 all [installed]
libwebkit2gtk-4.0-37/eoan-updates,eoan-security,now 2.26.2-0ubuntu0.19.10.1 amd64 [installed]
libwebkit2gtk-4.0-37/eoan-updates,eoan-security 2.26.2-0ubuntu0.19.10.1 i386
libwebkit2gtk-4.0-dev/eoan-updates,eoan-security 2.26.2-0ubuntu0.19.10.1 amd64
libwebkit2gtk-4.0-dev/eoan-updates,eoan-security 2.26.2-0ubuntu0.19.10.1 i386
libwebkit2gtk-4.0-doc/eoan-updates,eoan-updates,eoan-security,eoan-security

This precludes the use of wxWebView.

How to overcome this issue ?

Re: Ubuntu 19.10 & webkit

Posted: Fri Jan 24, 2020 9:18 pm
by ONEEYEMAN
Hi,
Which version of wxWidgets do you have?
How did you configured it?

Thank you.

Re: Ubuntu 19.10 & webkit

Posted: Fri Jan 24, 2020 9:19 pm
by DavidHart
Hi,

IIRC, it isn't possible to build wx3.1.2, and I presume 3.1.3, with webkit when configuring --with-gtk=2, but it is with gtk=3. Did you try that?

Regards,

David

Re: Ubuntu 19.10 & webkit

Posted: Fri Jan 24, 2020 10:36 pm
by raananb
I was trying with 3.1.3.

../configure --with-gtk=3

failed with
package gtk+-3.0 was not found in the pkg-config search path

The configure implies that GTK+ was not correctly installed.

My installation is vanilla from 19.10 ISO , (as a vbox guest with windows 10 host), with libgtk2.0-dev and libpng12 installed so that DialogBlocks could run.

Re: Ubuntu 19.10 & webkit

Posted: Fri Jan 24, 2020 10:47 pm
by ONEEYEMAN
Hi,
But you don't have libgtk-3.0-dev installed, right?
Because remember - you are trying to configure against GTK+3.0, so you need the appropriate packages on the box.

Also know, that GTK+2 and GTK+3 can co-exist.

Thank you.

Re: Ubuntu 19.10 & webkit

Posted: Sun Jan 26, 2020 4:45 pm
by raananb
19.10 is too problematic, so I went back to 18.04.

Following VZ advice in Trac, I added ',webview' to lib_std and the problem was resolved.