wxCheckBox is not displayed on KDE Plasma

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
suuvor
In need of some credit
In need of some credit
Posts: 1
Joined: Thu Sep 05, 2019 11:35 am

wxCheckBox is not displayed on KDE Plasma

Post by suuvor » Thu Sep 05, 2019 12:06 pm

I use wxWidgets on Ubuntu 16 KDE Plasma. Checkboxes are not displayed on this OS configuration - labels are displayed only.
The checkbox initialization is simple enough:

Code: Select all

m_checkBox = new wxCheckBox(this, wxID_ANY, _("Label")
When checkbox is checked, it has the same appearance - I see label only.
I noticed the same situation for radioboxes.

wxWidgets version is 3.1.1

How can this problem be resolved?
Thanks!

DavidHart
Site Admin
Site Admin
Posts: 3881
Joined: Thu Jan 12, 2006 6:23 pm
Location: IoW, UK

Re: wxCheckBox is not displayed on KDE Plasma

Post by DavidHart » Thu Sep 05, 2019 1:12 pm

Hi,
I use wxWidgets on Ubuntu 16 KDE Plasma.
I presume you mean 16.04 (xenial)
Checkboxes are not displayed on this OS configuration
I don't have a plain ubuntu xenial with kde installed. However checking on a 16.04 kubuntu live disc, check and radio boxes work fine in a program built against wx3.0.2.

You need to narrow the problem down. Is it just wx3.1.1, or does it happen with other wx versions? Is it just your program or can it be demonstrated in one of the wx samples (for the distro's wx the package is wx3.0-examples (or wx3.1) which installs to /usr/share/doc/wx-examples/ or /usr/share/doc/wx3.1-examples/).

But first, and easier: try a different theme, in case that is the cause. If so that would explain why it doesn't happen with kubuntu.

Regards,

David
Last edited by DavidHart on Tue Sep 10, 2019 9:01 am, edited 1 time in total.
Reason: Corrected error: s/lubuntu/kubuntu

Post Reply