libwxexpat missing

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
User avatar
Parduz
Experienced Solver
Experienced Solver
Posts: 58
Joined: Fri Jan 30, 2015 1:48 pm
Location: Bologna, Italy

libwxexpat missing

Post by Parduz » Thu Jun 06, 2019 10:38 am

I've built wxWidgets 3.0.4 on Debian9 using gcc 6.3

This was the configure command:

Code: Select all

../configure --disable-shared --disable-debug --with-gtk=2 --with-libtiff=no --with-opengl=no --enable-unicode
Now i'm trying to compile my app but i get a lot of error about undefined references.

The first ones are about XML, and I've found that i don't have any libwxexpat.

Why i don't have that library? what have i done wrong?
Attachments
config_log.txt
(195.13 KiB) Downloaded 11 times
compiler_log.txt
(10.44 KiB) Downloaded 11 times

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3525
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: libwxexpat missing

Post by ONEEYEMAN » Thu Jun 06, 2019 2:55 pm

Hi,
Why did you use "--disable-shared"?
And how exactly are you building your software? Using "wx-config"? By some other means? Can you build minimal sample?

Thank you.

Post Reply