wxWidgets-3.1.2 build on osx 10.14.3 configure error Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
raananb
Super wx Problem Solver
Super wx Problem Solver
Posts: 387
Joined: Fri Oct 27, 2006 4:35 pm
Location: Paris, France
Contact:

wxWidgets-3.1.2 build on osx 10.14.3 configure error

Post by raananb » Mon Mar 18, 2019 9:13 am

OSX 10.14.3 XCode 10.1 (10B61) wxWidgets-3.1.2 using /Library/Developer/CommandLineTools/SDKs/MacOSX.sdk (the shortcut MacOsx10.14.sdk in the same folder points to the same MacOSX.sdk)

configure --with-osx_cocoa --disable-debug --enable-unicode --disable-universal --disable-monolithic --enable-gui --disable-shared --enable-exceptions --without-opengl --enable-xrc --enable-html --with-regex=builtin --enable-richtext --disable-mediactrl --enable-aui --enable-ribbon --enable-propgrid --enable-stc CFLAGS='-arch x86_64' CXXFLAGS='-arch x86_64' LDFLAGS='-arch x86_64' OBJCFLAGS='-arch x86_64' OBJCXXFLAGS='-arch x86_64'

configure fails with the following error message:

configure:20282: error: in `.../wxWidgets-3.1.2/GCCBuildReleaseOSXCocoaUnicode':
configure:20284: error: no. Try a different SDK

Any idea aboout correcting this?

raananb
Super wx Problem Solver
Super wx Problem Solver
Posts: 387
Joined: Fri Oct 27, 2006 4:35 pm
Location: Paris, France
Contact:

Re: wxWidgets-3.1.2 build on osx 10.14.3 configure error

Post by raananb » Mon Mar 18, 2019 10:01 am

adding --with-macosx-version-min=10.14 solved the problem

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3592
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: wxWidgets-3.1.2 build on osx 10.14.3 configure error

Post by ONEEYEMAN » Mon Mar 18, 2019 2:44 pm

Hi,
10.14 SDK does not contain 10.8 SDK (minimum required for wx) anymore.

I believe the minimum required is raised in HEAD, so you won'r see it in the future.

Thank you.

Post Reply