sound sample doesn't work right, osx mojave

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
jbattle
Earned a small fee
Earned a small fee
Posts: 23
Joined: Mon Oct 01, 2007 8:48 pm
Location: Austin, TX

sound sample doesn't work right, osx mojave

Postby jbattle » Sun Jan 13, 2019 1:46 am

I have my application running fine on windows, and I'm just now getting it working for OSX. I was having problems with wxSound, so my first course of action was to build the samples/sound program, completely unmodified. It was built using the developer command line tools (that is, apple's faux gcc, no xcode) using just "make -f makefile.unx"

The shortest repro steps after building are:
[list]
[*]launch program
[*]Cmd-L (loop sound) ... and the sound does loop
[*]Cmd-T (stop playing) ... and the sound does stop playing
[*]Cmd-L (loop sound) ... silence
[/list]

Another sequence that fails:
[list]
[*]launch program
[*]Cmd-S (play synchronously) ... and it works as expected
[*]Cmd-S (play synchronously) ... nothing is heard and the spinning ball goes forever
[/list]

Can anyone else repro this on OSX or does this indicate some problem in my setup?

wx-3.1.2, no patches or modifications
Apple Developer Command Line tools
built with debug, no optimization
no setup.h tweaks, just the stock wx-3.1.2 build

[76 wx-3.1.2/samples/sound]wx-config --cxx
g++ -std=gnu++14 -isysroot /Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk -mmacosx-version-min=10.7 -stdlib=libc++

[77 wx-3.1.2/samples/sound]wx-config --cxxflags
-I/Users/jb/lib/wx/include/osx_cocoa-unicode-static-3.1 -I/Users/jb/include/wx-3.1 -D_FILE_OFFSET_BITS=64 -D__WXMAC__ -D__WXOSX__ -D__WXOSX_COCOA__

[78 wx-3.1.2/samples/sound]wx-config --libs
-L/Users/jb/lib -framework IOKit -framework Carbon -framework Cocoa -framework AudioToolbox -framework System -framework OpenGL /Users/jb/lib/libwx_osx_cocoau_xrc-3.1.a /Users/jb/lib/libwx_osx_cocoau_qa-3.1.a /Users/jb/lib/libwx_baseu_net-3.1.a /Users/jb/lib/libwx_osx_cocoau_html-3.1.a /Users/jb/lib/libwx_osx_cocoau_core-3.1.a /Users/jb/lib/libwx_baseu_xml-3.1.a /Users/jb/lib/libwx_baseu-3.1.a -framework WebKit -lwxtiff-3.1 -lwxjpeg-3.1 -lwxpng-3.1 -lwxregexu-3.1 -lwxscintilla-3.1 -lexpat -lz -framework Security -lpthread -liconv

Return to “Platform Related Issues”

Who is online

Users browsing this forum: No registered users and 7 guests