Page 1 of 1

wxwidgets app compiled on Deepin OS not working???

Posted: Fri Nov 16, 2018 5:15 pm
by davidlondonuk
Hi all,

This is a strange one. I have coded a small wxwidgets app that displays png files on an image panel. When I compile it on Ubuntu 18.04 it works perfectly - If I copy the same source-code folder over to deepin-15.8 and run the program it works perfectly. However, when I compile the exact same code on Deepin the png files do not display on either Deepin or on Ubuntu.

There is obviously something wrong with the deepin wxwidgets packages - I have exactly the same build-essential and wxwidgets packages on both Ubuntu and deepin. I know Deepin is now based on Debian unstable and was wondering if anyone had run in to this problem and if there is fix.

Thanks for any help.

Re: wxwidgets app compiled on Deepin OS not working???

Posted: Fri Nov 16, 2018 7:41 pm
by DavidHart
Hi,
There is obviously something wrong with the deepin wxwidgets packages
...or perhaps with the deepin libpng or its dependencies.

I suggest the first thing you should do is to check which wxWidgets compile/runtime versions you are using on each distro. The easy way to do that is: Ctl-Alt-Middleclick over the running program.

Next is to build and run relevant wxWidgets samples on deepin; they will probably be in a package called wx3.0-examples which installs to /usr/share/doc/wx-examples/ (read the README in /usr/share/doc/wx3.1-examples/examples/README.examples/). Then see if 'image' works; that has pngs.

If it does, then the problem must be elsewhere; perhaps even in your code ;) .

Regards,

David

Re: wxwidgets app compiled on Deepin OS not working???

Posted: Fri Nov 16, 2018 8:46 pm
by ONEEYEMAN
Hi,
davidlondonuk wrote: Hi all,

This is a strange one. I have coded a small wxwidgets app that displays png files on an image panel. When I compile it on Ubuntu 18.04 it works perfectly - If I copy the same source-code folder over to deepin-15.8 and run the program it works perfectly.
This is not a reliable test - you should recompile the code and produce the new binary on the new OS.
davidlondonuk wrote: However, when I compile the exact same code on Deepin the png files do not display on either Deepin or on Ubuntu.

There is obviously something wrong with the deepin wxwidgets packages - I have exactly the same build-essential and wxwidgets packages on both Ubuntu and deepin. I know Deepin is now based on Debian unstable and was wondering if anyone had run in to this problem and if there is fix.

Thanks for any help.
[/quote]

Check that wx version is the same, png version is the same.
Then try to run the sample as suggested by David.

Thank you.

Re: wxwidgets app compiled on Deepin OS not working???

Posted: Fri Nov 16, 2018 9:39 pm
by davidlondonuk
Thanks for the answers but it gets worse.

I removed all the debian wxwidgets packages from deepin os, installed gtk-3-dev and compiled wxwidgets-3.0.4 from source - and compiled my app again. The program compiled without a hitch but I still have the same problem - the png files will not display on the image panel??? I'm back to square one.

Wxwidgets compiled with it's built-in png and jpeg code, could that be the problem? I am stumped.

The only error occurred when I ran the program:

dbind-WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files

I have no idea what that means??

Thanks for any help.

Re: wxwidgets app compiled on Deepin OS not working???

Posted: Fri Nov 16, 2018 10:15 pm
by doublemax
I can't help with the Linux-side of things, but in any case you should try to narrow down the problem a little more.

Most important: Build and run the "image" sample that comes with wxWidgets. If it displays all images correctly, you know that the problem lies somewhere in your project.

Regarding your project: Find out if the loading of the PNG fails or the display. If the loading fails, check if it also happens when you load a JPG.