wxCollapsiblePane - not expanding correctly on Linux

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
deepti
Experienced Solver
Experienced Solver
Posts: 95
Joined: Tue Jul 17, 2018 5:38 pm

wxCollapsiblePane - not expanding correctly on Linux

Post by deepti » Mon Sep 24, 2018 11:37 am

Hi,

I have the following code, which adds a custom wxCollapsiblePane to a wxScrolledWindow instance.
I am calling the "Collapse(false)" function on the newly added wxCollapsiblePane instance, and also calling SetSizeHints and FitInside on the containing sizer. This issue is seen only on Linux. On Windows and Mac, it displays correctly.

What else should i be doing? Please help!

Code: Select all

	metadataSetCollapsiblePane *collpane = new metadataSetCollapsiblePane(m_metaDataScrolledWindow, collpaneID, (*(metadataElement))["name"], wxDefaultPosition/*, wxSize(300, 30)*/);
	if(bNewlyAdded)
		collpane->Collapse(false);
	itemGridSizer->Add(collpane, 1, wxEXPAND , 0);
	
	m_metaDataControlsbox->SetSizeHints(m_metaDataScrolledWindow);
	m_metaDataScrolledWindow->FitInside();
	m_metaDataControlsbox->FitInside(m_metaDataScrolledWindow);
	m_metaDataControlsbox->Layout();
m_metaDataControlsbox contains "itemGridSizer", and is the sizer associated with m_metaDataScrolledWindow
Last edited by deepti on Tue Sep 25, 2018 12:29 pm, edited 1 time in total.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 3352
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: wxCollapsiblePane - not expanding correctly on Linux

Post by ONEEYEMAN » Mon Sep 24, 2018 3:59 pm

Hi,
Are you compiling against GTK+2 or GTK+3? Which exact version?

Thank you.

deepti
Experienced Solver
Experienced Solver
Posts: 95
Joined: Tue Jul 17, 2018 5:38 pm

Re: wxCollapsiblePane - not expanding correctly on Linux

Post by deepti » Mon Sep 24, 2018 5:19 pm

I think it is GTK3.

The command "dpkg -l libgtk2.0-0 libgtk-3-0" gives the following output:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii libgtk-3-0 3.4.2-0ubuntu0 GTK+ graphical user interface library
ii libgtk2.0-0 2.24.10-0ubunt GTK+ graphical user interface library


And the command "dpkg-query -W libgtk-3-bin", gives the output below:

libgtk-3-bin 3.4.2-0ubuntu0.8


Is this the right way to check?

Please also note that I am using Ubuntu 12.04 version and wxWidgets 3.1.0.

Post Reply