Error launching "minimal" under Windows 10

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
dbetz
Earned a small fee
Earned a small fee
Posts: 11
Joined: Mon Nov 13, 2006 4:10 am

Re: Error launching "minimal" under Windows 10

Postby dbetz » Thu Apr 05, 2018 6:53 pm

PB wrote:
dbetz wrote:I just followed the instructions in the docs\msw\install.txt file and it didn't say anything about setting up a build environment. How do I do that?


I meant what the docs describe as step 0
Open a "Visual Studio Command Prompt" window shortcut to which
must have been installed to the "Start" menu or the "Start" screen
by MSVS installation.

Yes, I performed this step. I can try invoking the batch file directly. When I used nmake, the build completed successfully. I just couldn't run the resulting program because of the error I mentioned at the start of this thread. Maybe the problem was that the default build with nmake uses SDK 8.1 and I only have SDK 10.

PB
Part Of The Furniture
Part Of The Furniture
Posts: 1756
Joined: Sun Jan 03, 2010 5:45 pm

Re: Error launching "minimal" under Windows 10

Postby PB » Thu Apr 05, 2018 7:14 pm

dbetz wrote:Maybe the problem was that the default build with nmake uses SDK 8.1 and I only have SDK 10.


I believe that unlike MSVS solutions, makefiles do not specify an SDK version (which is is taken from the nmake build environment), so the same one should be used for both library and sample automatically.

dbetz
Earned a small fee
Earned a small fee
Posts: 11
Joined: Mon Nov 13, 2006 4:10 am

Re: Error launching "minimal" under Windows 10

Postby dbetz » Thu Apr 05, 2018 7:42 pm

PB wrote:
dbetz wrote:Maybe the problem was that the default build with nmake uses SDK 8.1 and I only have SDK 10.


I believe that unlike MSVS solutions, makefiles do not specify an SDK version (which is is taken from the nmake build environment), so the same one should be used for both library and sample automatically.

In that case I don't now why it failed to use SDK 10.


Return to “Platform Related Issues”

Who is online

Users browsing this forum: No registered users and 5 guests