Can't build on SuSE 9.1

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
Tux
In need of some credit
In need of some credit
Posts: 1
Joined: Fri Oct 29, 2004 3:34 pm
Location: Netherlands

Can't build on SuSE 9.1

Post by Tux » Mon Nov 01, 2004 9:03 am

I'm sure I posted a message, but apparently it didn't come through

Jouke pointed me to wxWidgets. I'm quite used to perl/Tk, and willing to try to also use wxPerl and have some speed comparisons, since I'm not happy with the image handling speed for perl/Tk with Image::Magick

Since I didn't manage to build the wx-0.20 after having updated all wx related stuff to latest from SuSE, I tried to compile 3.5.3 + patch from scratch, which failed.

lt09:/pro/3gl/wxGTK-2.5.3 102 > make
./bk-deps g++ -c -o advdll_grid.o -I.pch/wxprec_advdll -D__WXGTK__ -I./src/regex -DWXUSINGDLL -DWXMAKINGDLL_ADV -fPIC -DPIC -DWX_PRECOMP -DNO_GCC_PRAGMA -DGTK_NO_CHECK_CASTS -Ilib/wx/include/gtk2-unicode-release-2.5 -I./include -pthread -I/usr/local/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/opt/gnome/include/gtk-2.0 -I/opt/gnome/lib/gtk-2.0/include -I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -O2 -I/usr/local/include/pango-1.0 -I/usr/X11R6/include -I/usr/include/freetype2 -I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include -pthread -Wall src/generic/grid.cpp
src/generic/grid.cpp: In member function `virtual void wxGridCellFloatEditor::StartingKey(wxKeyEvent&)':
src/generic/grid.cpp:1076: error: `wxLocale' has not been declared
src/generic/grid.cpp:1076: error: `wxLOCALE_DECIMAL_POINT' undeclared (first use this function)
src/generic/grid.cpp:1076: error: (Each undeclared identifier is reported only once for each function it appears in.)
src/generic/grid.cpp:1076: error: `wxLOCALE_CAT_NUMBER' undeclared (first use this function)
src/generic/grid.cpp:1076: error: `GetInfo' undeclared (first use this function)
src/generic/grid.cpp: In member function `virtual bool wxGridCellFloatEditor::IsAcceptedKey(wxKeyEvent&)':
src/generic/grid.cpp:1185: error: `wxLocale' has not been declared
src/generic/grid.cpp:1185: error: `wxLOCALE_DECIMAL_POINT' undeclared (first use this function)
src/generic/grid.cpp:1186: error: `wxLOCALE_CAT_NUMBER' undeclared (first use this function)
src/generic/grid.cpp:1186: error: `GetInfo' undeclared (first use this function)
make: *** [advdll_grid.o] Error 1
Exit 2
lt09:/pro/3gl/wxGTK-2.5.3 103 >

from config.status

configured by configure, generated by GNU Autoconf 2.59,
with options \"'--prefix=/pro' '--disable-nls' '--disable-intl' '--enable-unicode'\"

I realize the above failure might be from --disable-nls --disable-intl, but that is what I wanted. I don't care for locales, locale support, and the bloat (IMHO) that comes with it. I'm in it for speed, and I've never seen any application *gain* speed from locale support.

Anyway, If I do configure without the two disables, after a make distclean, it still fails
but starting from scratch (rm -rf):

# configure --prefix=/pro --enable-unicode

Configured wxWidgets 2.5.3 for `i686-pc-linux-gnu'

Which GUI toolkit should wxWidgets use? GTK+ 2
Should wxWidgets be compiled into single library? no
Should wxWidgets be compiled in debug mode? no
Should wxWidgets be linked as a shared library? yes
Should wxWidgets be compiled in Unicode mode? yes
What level of wxWidgets compatibility should be enabled?
wxWidgets 2.2 no
wxWidgets 2.4 yes
Which libraries should wxWidgets use?
jpeg sys
png sys
regex builtin
tiff sys
zlib sys
odbc no
expat sys
libmspack no
sdl no

All passes.
No tests?

lt09:/pro/3gl/wxGTK-2.5.3 121 > make test
make: *** No rule to make target `test'. Stop.
Exit 2
lt09:/pro/3gl/wxGTK-2.5.3 122 > make check
make: *** No rule to make target `check'. Stop.
Exit 2
lt09:/pro/3gl/wxGTK-2.5.3 123 >

gcc-3.4.2, SuSE 9.1 2.6.5-7.111-default
Enjoy, Have FUN! H.Merijn

Post Reply