MAC Illustrator SDK

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
Anatoliy2
In need of some credit
In need of some credit
Posts: 1
Joined: Mon Sep 26, 2016 3:55 pm

MAC Illustrator SDK

Post by Anatoliy2 » Mon Sep 26, 2016 4:27 pm

Hello.

I use MAC OS X , XCode and Illustrator SDK to develop an Illustrator Plugin.
When I include the wxWidgets library to my project I have some strange issue. My plugin can not load within Illusrtator unless I run Illustrator with XCode debug enabled.

To reproduce this issue:
1. download Illustrator SDK;
2. open sample project "EmptyPanel";
3. include the wxWidgets library to opened project:
- add wxcocoa.xcodeproj to project;
- inside the "Build Phases" of the EmptyPanel Project add the dinamic to Target Dependencies, and add the libwx_osx_cocoa.dylib to the Link Binary With Libraries;
- add "$(WXROOT)/include $(WXROOT)/build/osx/setup/$(WXTOOLKIT)/include" to the "User Header Search Path" of the Build Settings of the EmptyPanel project.
- add "WXBUILDING $(WXPLATFORM) WX FILE_OFFSET_BITS=64 LARGE_FILES MACOS_CLASSIC _WXMAC_XCODE__=1 SCI_LEXER WX_PRECOMP=1 wxUSE_UNICODE_UTF8=0 wxUSE_UNICODE_WCHAR=1 WCHAR_H_CPLUSPLUS_98_CONFORMANCE_" to the "Preprocessor Macros"
4. build and copy the EmptyPanel.aip to the Plug-ins folder of the Illustrator.
5. Run Illustrator and you will see the aip file does not load.

But when you run the Illustrator through the XCode in debug mode, it works well.

Please could some one help me to load EmptyPanel plugin with wxWidgets library?

Thanks,

Anatoliy

Post Reply