[b]how to run application where wxWidgets libs are not built

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
hassan_ashraf_sahi
In need of some credit
In need of some credit
Posts: 2
Joined: Fri Sep 16, 2005 2:54 pm
Contact:

[b]how to run application where wxWidgets libs are not built

Post by hassan_ashraf_sahi » Fri Sep 16, 2005 3:05 pm

Hello every one
i have successfully built wxWidgets 2.6.2 on Red Hat Linux 9
and have developed the application as well
but when i wanted to start the app it asked for the libraries so i added the required libs in LD_LIBRARY_PATH

HOW CAN I RUN MY APP WHERE I HAVE NO WXWIDGETS LIB BUILT???

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Fri Sep 16, 2005 3:28 pm

Hi!
WHAT ABOUT LINKING THE APP STATICALLY WITH WXWIDGETS?

Next time please don't shout.
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

hassan_ashraf_sahi
In need of some credit
In need of some credit
Posts: 2
Joined: Fri Sep 16, 2005 2:54 pm
Contact:

Post by hassan_ashraf_sahi » Sat Sep 17, 2005 1:16 pm

how do i statically link my app to wxwidgets libs?

cg
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 201
Joined: Sun Aug 29, 2004 12:33 am
Location: Canada
Contact:

Post by cg » Sat Sep 17, 2005 3:40 pm

On the configure like add:

--enable-static

Example:

./configure --with-gtk --enable-static

HTH

Chris

Post Reply