[wx2.6] wxProgressDialog stalled on Linux after Update Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
User avatar
baert
I live to help wx-kind
I live to help wx-kind
Posts: 169
Joined: Wed Sep 15, 2004 1:52 pm
Location: France - Compiegne-Paris-Lille

[wx2.6] wxProgressDialog stalled on Linux after Update

Post by baert » Thu Sep 01, 2005 12:52 pm

Hi,

I have a wxProgressDialog used during the "login step of my app)

it is working fine on Windows and WinCE

On linux I have an issue:

after the first update the dialog box stop and the program never reach the next statment...

Code: Select all

bool CTPSoftsetUI::OnLogin( CLoginEvent& event )
{
	m_pMainFrame->SetCursor(*wxHOURGLASS_CURSOR);
     

	wxProgressDialog* myProgDialog = new wxProgressDialog(wxT("Logging-In..."), 
 			 wxT("Login in...\n"),
 			 100, m_pMainFrame, wxPD_AUTO_HIDE | wxPD_APP_MODAL | wxPD_SMOOTH);
	
cout << "Step 1 OK" << endl;
myProgDialog->Update(5);
cout << "step 2 .. never going here..." << endl;
   
....
}
So the output is never showing "step 2 .. never going here..." ... (I have "Step 1 OK" )

Any idea ?
Bart

upCASE
Site Admin
Site Admin
Posts: 3176
Joined: Mon Aug 30, 2004 6:55 am
Location: Germany, Cologne

Post by upCASE » Thu Sep 01, 2005 1:19 pm

Hmmm... Just an idea: Does it work when not using wxPD_APP_MODAL?
OS: OpenSuSE, Ubuntu, Win XP Pro
wx: svn
Compiler: gcc 4.5.1, VC 2008, eVC 4

"If it was hard to write it should be hard to read..." - the unknown coder
"Try not! Do. Or do not. There is no try." - Yoda

User avatar
baert
I live to help wx-kind
I live to help wx-kind
Posts: 169
Joined: Wed Sep 15, 2004 1:52 pm
Location: France - Compiegne-Paris-Lille

Post by baert » Thu Sep 01, 2005 1:30 pm

it doesn't change anything ... :cry:
Bart

ssigala
Earned some good credits
Earned some good credits
Posts: 109
Joined: Fri Sep 03, 2004 9:30 am
Location: Brescia, Italy

Post by ssigala » Thu Sep 01, 2005 3:02 pm

Very strange... m_pMainFrame is the actual parent when the OnLogin() function gets called, or there is another frame (perhaps a dialog)?

Try changing m_pMainFrame with NULL and see if something change.
Sandro Sigala - Kynosoft, Brescia

User avatar
baert
I live to help wx-kind
I live to help wx-kind
Posts: 169
Joined: Wed Sep 15, 2004 1:52 pm
Location: France - Compiegne-Paris-Lille

Post by baert » Thu Sep 01, 2005 5:47 pm

doesn't work either ...
Bart

User avatar
baert
I live to help wx-kind
I live to help wx-kind
Posts: 169
Joined: Wed Sep 15, 2004 1:52 pm
Location: France - Compiegne-Paris-Lille

Post by baert » Fri Sep 02, 2005 9:10 am

can it have some correspondance with any Multithreading flags ??
I mean may be I did some mistakes compiling wxWidgets ??

I'll check if there is any special flag for multithreading ???

or could it be in my own program ??
Bart

User avatar
baert
I live to help wx-kind
I live to help wx-kind
Posts: 169
Joined: Wed Sep 15, 2004 1:52 pm
Location: France - Compiegne-Paris-Lille

Post by baert » Fri Sep 02, 2005 1:12 pm

OK, I get the flags from the "thread" sample,
now the progress bar is OK, it was in effect a thread problem.

anyway thanks for your help.

Bart
Bart

Post Reply