xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
thestomper
In need of some credit
In need of some credit
Posts: 2
Joined: Wed Apr 03, 2013 4:22 pm

xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!

Post by thestomper » Wed Apr 03, 2013 4:36 pm

Hey guys,
I also am new to this and i believe this was not yet answered in a different thread but i am stuck:

My System:
Max OS X 10.8.2
xCode 4.6
wxWidgets 2.9.4

I tried Compiling wxWidgets using the command-line (http://wiki.wxwidgets.org/Compiling_wxW ... erminal%29)
but it would not work right after configuring (which i tried with several attributes) the terminal gives me a list of operations ending with:

Code: Select all

checking for --enable-webviewie... yes
checking for --enable-autoidman... no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/Users/MyUser/wxWidgets-2.9.4/build-debug':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
It seems to me that these last 2 "configure: error:" lines are important -
I extracted the wxWidgets file in my User Home directory ( Users/MyUser ) is that a problem?

Can anybody help?
It seems to me that wxWidgets is not making it easy, and i can't find any help with more recent versions of OS X & xCode....

thanks!

bcteh
Experienced Solver
Experienced Solver
Posts: 72
Joined: Mon Nov 27, 2006 9:56 am

Re: xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!

Post by bcteh » Fri Apr 05, 2013 9:47 am

You didn't install c/c++ compiler.

Open XCode go to preferences under downloads install command line tools

thestomper
In need of some credit
In need of some credit
Posts: 2
Joined: Wed Apr 03, 2013 4:22 pm

Re: xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!

Post by thestomper » Wed Apr 10, 2013 11:46 am

Thanks, I missed that!

It seems to work now ;-)

Post Reply