Linux/wxGTK didn't compile properly? Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Linux/wxGTK didn't compile properly?

Post by ONEEYEMAN » Tue Aug 16, 2005 3:51 am

Hi, ALL,
I am using wxGTK/wxWindows 2.6.1. On Windows everything works as expected.
On Linux (using Gentoo/Portage) I compiled the library, but whe I started porting, KDevelop said:

Code: Select all

You must set wxUSE_DOC_VIEW_ARCHITECTURE to 1 in setup.h!
Does this mean the library is not configured properly and I have to re-compile?

Thank you in advance.

KevinHock
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 236
Joined: Sat Sep 04, 2004 1:49 pm
Location: Ohio, USA
Contact:

Post by KevinHock » Tue Aug 16, 2005 4:03 am

Yes, it means you are trying to use Doc/View but the library was not compiled with Doc/View support. You will need to make the change indicated and recompile the library to add the Doc/View support.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Tue Aug 16, 2005 4:07 am

Thank you.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Wed Aug 17, 2005 12:43 am

Is it enough to put the "configure" option, or I will have to do it manually?

Thank you.

KevinHock
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 236
Joined: Sat Sep 04, 2004 1:49 pm
Location: Ohio, USA
Contact:

Post by KevinHock » Wed Aug 17, 2005 1:58 am

The configure option will simply generate the change to setup.h, so you can do it either way. Manually changing setup.h will be faster however since you don't have to re-run configure.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Wed Aug 17, 2005 8:11 am

Thank you for the reply, but...
I just recompile the whole wxGTK-2.6.1 to make sure I turned on this option, and I did, but it still gives me this error, and it doesn't recognize the wxMDIXXX classes.
I could post the configure output, but it loks like there might be a problem either with wxGTK configure for 2.6.1 or in Gentoo Portage ebuild.

Could somebody confirm that the wxGTK-2.6.1 compiles and runs with the Doc/View MDI support enabled correctly?

I am gonna post the problem in the Gentoo forum as well, see what might be the responce.

Thank you.

KevinHock
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 236
Joined: Sat Sep 04, 2004 1:49 pm
Location: Ohio, USA
Contact:

Post by KevinHock » Wed Aug 17, 2005 1:47 pm

It appears the deeper answer to your question may be that MDI is not implemented on Linux, see: http://forums.wxwidgets.org/viewtopic.php?t=3011

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Wed Aug 17, 2005 5:18 pm

Can somebody from development or site admin confirm, please?

Thank you.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Thu Aug 18, 2005 11:18 pm

Anybody?

Ryan/upCASE/Developers/opther site admin/moderators/etc

Please confirm

Thank you in advance.

User avatar
Ryan Norton
Moderator
Moderator
Posts: 1319
Joined: Mon Aug 30, 2004 6:01 pm

Post by Ryan Norton » Fri Aug 19, 2005 12:11 am

I'm not sure - I heard it was implemented on linux with tabs
[Mostly retired moderator, still check in to clean up some stuff]

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 4152
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Post by ONEEYEMAN » Sun Aug 21, 2005 6:25 am

Thank you for the reply, all.
I will look into it and post the findings here in case somebody else wondering.

Thank you.

Post Reply