Windows console launched with my app... Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
Muetdhiver
Super wx Problem Solver
Super wx Problem Solver
Posts: 323
Joined: Sun Jun 08, 2008 11:59 am
Location: Bordeaux, France

Windows console launched with my app...

Post by Muetdhiver » Sun Feb 05, 2012 10:19 am

Hi,

I'm working under Ubuntu, I've made an application and I try to port it under windows.
After compiling it with Eclipse / GCC toolchain, I've got an executable.

When I run it, two windows appear : my program, and a console (DOS) window, black with nothing into.
I don't know how to remove it.

I already compiled my program under windows last year with wx2.8, and I don't remember this problem occured.
Now I'm with wx 2.9.3.

How to remove the console joined to the main program ?
Is there really a wxWidgets problem or it can be a link with Eclipse project configuration ?

Thanks for the help.
OS: Ubuntu 11.10
Compiler: g++ 4.6.1 (Eclipse CDT Indigo)
wxWidgets: 2.9.3

briceandre
Ultimate wxWidgets Guru
Ultimate wxWidgets Guru
Posts: 670
Joined: Tue Aug 31, 2010 6:22 am
Location: Belgium

Re: Windows console launched with my app...

Post by briceandre » Tue Feb 07, 2012 1:03 pm

You should add something like this during your link process :
g++ -Wl,--subsystem,windows -mwindows

Muetdhiver
Super wx Problem Solver
Super wx Problem Solver
Posts: 323
Joined: Sun Jun 08, 2008 11:59 am
Location: Bordeaux, France

Re: Windows console launched with my app...

Post by Muetdhiver » Fri Feb 17, 2012 2:21 pm

Yes, this is the solution ! Thanks a lot for your help.

Bye.
OS: Ubuntu 11.10
Compiler: g++ 4.6.1 (Eclipse CDT Indigo)
wxWidgets: 2.9.3

Post Reply