wxWidgets on vista Topic is solved

Do you have a typical platform dependent issue you're battling with ? Ask it here. Make sure you mention your platform, compiler, and wxWidgets version.
Post Reply
rrcn
Earned a small fee
Earned a small fee
Posts: 14
Joined: Mon Nov 17, 2008 4:57 pm

wxWidgets on vista

Post by rrcn » Mon Nov 17, 2008 5:06 pm

I want to use wxWidgets on vista with visual express c++ 2008.
The install tutorial says the instructions are for windows xp.
I tried for myself on vista but a very simple c++ application gives me 2 link errors: unresolved external symbol.
Can I still use wxWidgets on vista?

User avatar
T-Rex
Moderator
Moderator
Posts: 1204
Joined: Sat Oct 23, 2004 9:58 am
Location: Zaporizhzhya, Ukraine
Contact:

Post by T-Rex » Wed Nov 19, 2008 9:24 pm

You can use wxWidgets under Vista.
If you post the build log of your application then it is possible that someone will suggest the solution of your problem.

Romas
I live to help wx-kind
I live to help wx-kind
Posts: 176
Joined: Mon Jun 16, 2008 11:07 am
Location: Kaunas

Post by Romas » Fri Nov 21, 2008 11:22 am

I am using wxWidgets on Windows Vista with latest Visual Studio express without a problem. If you explain what are you trying to do we can find the solution.

illnatured
Filthy Rich wx Solver
Filthy Rich wx Solver
Posts: 234
Joined: Mon May 08, 2006 12:31 pm
Location: Krakow, Poland

Post by illnatured » Fri Nov 21, 2008 11:42 am

It has nothing to do with Vista. If you get 'unresolved external symbol' errors, then you're not linking against proper libs. Make sure you have followed the tutorial carefully.

rrcn
Earned a small fee
Earned a small fee
Posts: 14
Joined: Mon Nov 17, 2008 4:57 pm

Post by rrcn » Fri Nov 28, 2008 5:44 pm

The problem was with the preprocessor definitions.
It's ok now.
I've copied the ones from the minimalist example.
Sorry for only replying to the answers now!

Post Reply